summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/cabextract')
-rw-r--r--app-arch/cabextract/Manifest1
-rw-r--r--app-arch/cabextract/cabextract-1.6.ebuild35
-rw-r--r--app-arch/cabextract/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/app-arch/cabextract/Manifest b/app-arch/cabextract/Manifest
new file mode 100644
index 000000000000..61f11f2cfaef
--- /dev/null
+++ b/app-arch/cabextract/Manifest
@@ -0,0 +1 @@
+DIST cabextract-1.6.tar.gz 241731 SHA256 cee661b56555350d26943c5e127fc75dd290b7f75689d5ebc1f04957c4af55fb SHA512 d1c71c0292e3d73d8edbff5f5230b3127c63028f5aba1d0cad968bc945202fb9c0773327affce3d28466068377f029c80735adbabe0929d29b2204dea73738f8 WHIRLPOOL 5816e3f6ee3a3caad574bbc3d8aeff55bb99383a4ce80a40332d59696a1d4fbaba6823e9a77023e7cbbc257a0693a35f7817d7ff20383b30898de5d4e50eb1f2
diff --git a/app-arch/cabextract/cabextract-1.6.ebuild b/app-arch/cabextract/cabextract-1.6.ebuild
new file mode 100644
index 000000000000..a56604b18651
--- /dev/null
+++ b/app-arch/cabextract/cabextract-1.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Extracts files from Microsoft cabinet archive files"
+HOMEPAGE="http://www.cabextract.org.uk/"
+SRC_URI="http://www.cabextract.org.uk/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="extras"
+
+RDEPEND="extras? ( dev-lang/perl )"
+
+# the code attempts to set up a fnmatch replacement, but then fails to code
+# it properly leading to undefined references to rpl_fnmatch(). This may be
+# removed in the future if building still works by setting "yes" to "no".
+export ac_cv_func_fnmatch_works=yes
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO doc/magic
+ dohtml doc/wince_cab_format.html
+ if use extras; then
+ dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
+ fi
+}
diff --git a/app-arch/cabextract/metadata.xml b/app-arch/cabextract/metadata.xml
new file mode 100644
index 000000000000..78a6f5f7ea4a
--- /dev/null
+++ b/app-arch/cabextract/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>fonts</herd>
+ <use>
+ <flag name="extras">Install experimental extra tools: wince_info and
+ wince_rename for examining and processing Windows CE installation cabinet
+ header files; cabinfo for examining the structure of a cab file.
+ </flag>
+ </use>
+</pkgmetadata>