summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/deb2targz/deb2targz-1-r2.ebuild')
-rw-r--r--app-arch/deb2targz/deb2targz-1-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/deb2targz/deb2targz-1-r2.ebuild b/app-arch/deb2targz/deb2targz-1-r2.ebuild
new file mode 100644
index 000000000000..c439c092ead7
--- /dev/null
+++ b/app-arch/deb2targz/deb2targz-1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit base
+
+DESCRIPTION="Convert a .deb file to a .tar.gz archive"
+HOMEPAGE="http://www.miketaylor.org.uk/tech/deb/"
+SRC_URI="http://www.miketaylor.org.uk/tech/deb/${PN}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~ppc-aix ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}/${PN}-any-data.patch" )
+
+src_unpack() {
+ cp "${DISTDIR}/${PN}" "${S}"
+}
+
+src_install() {
+ dobin ${PN}
+}