summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lcab/lcab-1.0_beta12.ebuild')
-rw-r--r--app-arch/lcab/lcab-1.0_beta12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/lcab/lcab-1.0_beta12.ebuild b/app-arch/lcab/lcab-1.0_beta12.ebuild
new file mode 100644
index 000000000000..a0e971bf82ea
--- /dev/null
+++ b/app-arch/lcab/lcab-1.0_beta12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="CAB file creation tool"
+HOMEPAGE="http://ohnopub.net/lcab/"
+SRC_URI="ftp://mirror.ohnopub.net/mirror/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i "s:1.0b11:${MY_PV}:" mytypes.h || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}