summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lrzip')
-rw-r--r--app-arch/lrzip/Manifest3
-rw-r--r--app-arch/lrzip/files/lrzip-missing-stdarg_h.patch11
-rw-r--r--app-arch/lrzip/lrzip-0.614.ebuild36
-rw-r--r--app-arch/lrzip/lrzip-0.616.ebuild36
-rw-r--r--app-arch/lrzip/lrzip-0.621.ebuild36
-rw-r--r--app-arch/lrzip/metadata.xml14
6 files changed, 136 insertions, 0 deletions
diff --git a/app-arch/lrzip/Manifest b/app-arch/lrzip/Manifest
new file mode 100644
index 000000000000..3e3cd77746f7
--- /dev/null
+++ b/app-arch/lrzip/Manifest
@@ -0,0 +1,3 @@
+DIST lrzip-0.614.tar.bz2 491995 SHA256 65024d69d1773f3ccf84508a481d7de128c03d1cf9750b5803aead4a24522763 SHA512 6c82d7b4cc6081fb4f102a34f3a5ecf834b3fa3d222ac9dd4f3f0615c83610c08315eae9cc98291bd5e3eb71453cf391cdad4db980012e4368d16d80f34d2bd8 WHIRLPOOL 1669d9e551786f81c3849b2bfb813422cccc21c9d00104b58d42a0470ae9b8633339ef88ead6c5956eea92ac6800ee9b259fbfb15d1b22aa45fe92db7040cf68
+DIST lrzip-0.616.tar.bz2 493886 SHA256 982d5a8db4d8bbbced6e33fbbcd589c9b3fc4275110155d7bd71cbeff4a235ae SHA512 f578034fa41c5be6df9b9d8e7efe5014229e1acecdd5d6090c26322e1e46db98e3bc17d780eca96342a0bcb56b8e78b008b3293520b82c1bbbd5a96e423d4b3f WHIRLPOOL bc7b22a579de42657c46f4dad426dfdb5cc37e1f54955cb66722ccbfc9b66d19194eb1f1a4d9f545de7859de7903d57854a1af647ff6c3341907fcc874351d94
+DIST lrzip-0.621.tar.bz2 503286 SHA256 31c26fbee8b9b0bd413ca214862dbc0d9e6d3477f23e9839774936bf140ceb6b SHA512 be94f54c3d84c93e3c1ab7b08ca6d2a02bc343983785be4884f42521520d2babc31db3abbec4b77dc9f710d18648adcc3d24b203289d8d4728afb3ef0fb90c0a WHIRLPOOL 41bd08db70f30ff183f3e82e784a40b08070a3a728eafad50b64c7ce453ed2c379721be64d0ac0ee04e1c66b6ad528d0210977624a8c17f90775f70b83921ae7
diff --git a/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch b/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch
new file mode 100644
index 000000000000..dcc698bd9b93
--- /dev/null
+++ b/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch
@@ -0,0 +1,11 @@
+diff -Naur Lrzip.h.orig Lrzip.h
+--- Lrzip.h.orig 2013-11-30 20:07:27.343086997 +0000
++++ Lrzip.h 2013-11-30 20:07:44.072641056 +0000
+@@ -22,6 +22,7 @@
+
+ #include <stdbool.h>
+ #include <stdio.h>
++#include <stdarg.h>
+ #ifdef _WIN32
+ # include <stddef.h>
+ #else
diff --git a/app-arch/lrzip/lrzip-0.614.ebuild b/app-arch/lrzip/lrzip-0.614.ebuild
new file mode 100644
index 000000000000..8875c9c27661
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.614.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="http://ck.kolivas.org/apps/lrzip/README"
+SRC_URI="http://ck.kolivas.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ~mips ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-libs/lzo
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ virtual/perl-Pod-Parser"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-missing-stdarg_h.patch
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${P}"
+}
+
+src_install() {
+ default
+ rm "${D}/usr/share/doc/${P}/COPYING"
+}
diff --git a/app-arch/lrzip/lrzip-0.616.ebuild b/app-arch/lrzip/lrzip-0.616.ebuild
new file mode 100644
index 000000000000..d05e78a5b0a5
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.616.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="http://ck.kolivas.org/apps/lrzip/README"
+SRC_URI="http://ck.kolivas.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-libs/lzo
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ virtual/perl-Pod-Parser"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-missing-stdarg_h.patch
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${P}"
+}
+
+src_install() {
+ default
+ rm "${D}/usr/share/doc/${P}/COPYING"
+}
diff --git a/app-arch/lrzip/lrzip-0.621.ebuild b/app-arch/lrzip/lrzip-0.621.ebuild
new file mode 100644
index 000000000000..176ae3410787
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.621.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="http://ck.kolivas.org/apps/lrzip/README"
+SRC_URI="http://ck.kolivas.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-libs/lzo
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ virtual/perl-Pod-Parser"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-missing-stdarg_h.patch
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${P}"
+}
+
+src_install() {
+ default
+ rm "${D}/usr/share/doc/${P}/COPYING"
+}
diff --git a/app-arch/lrzip/metadata.xml b/app-arch/lrzip/metadata.xml
new file mode 100644
index 000000000000..47c8a7fd5cf7
--- /dev/null
+++ b/app-arch/lrzip/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This is a compression program optimised for large files. The larger the
+ file and the more memory you have, the better the compression advantage
+ this will provide, especially once the files are larger than 100MB.
+ The advantage can be chosen to be either size (much smaller than bzip2)
+ or speed (much faster than bzip2).
+ </longdescription>
+</pkgmetadata>