summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/stormlib/files')
-rw-r--r--app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch (renamed from app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch)24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch b/app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch
index 66b8f91183f0..f50dcaa82601 100644
--- a/app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch
+++ b/app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch
@@ -1,6 +1,6 @@
-From f89f1341cf59f7098af985ecd683d5e0407d2dc7 Mon Sep 17 00:00:00 2001
+From 8cb9b76a5e85ffab436f7b01ecfc0a0dea7547af Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 20 Dec 2020 10:52:34 +0100
+Date: Mon, 3 Oct 2022 20:49:31 +0200
Subject: [PATCH] cmake: Use GNUInstallDirs for configurable install
directories
@@ -13,24 +13,24 @@ rather than 'lib'.
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index bd8d336..2b09191 100644
+index 9cf1050..b10c2c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -4,6 +4,7 @@ cmake_minimum_required(VERSION 2.8.12)
- set(LIBRARY_NAME storm)
+@@ -7,6 +7,7 @@ set(CMAKE_CXX_EXTENSIONS OFF)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
include(CMakeDependentOption)
+include(GNUInstallDirs)
option(BUILD_SHARED_LIBS "Compile shared libraries" OFF)
option(STORM_SKIP_INSTALL "Skip installing files" OFF)
-@@ -331,12 +332,12 @@ endif()
+@@ -357,12 +358,12 @@ endif()
if (NOT STORM_SKIP_INSTALL)
- install(TARGETS ${LIBRARY_NAME}
-- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib
+ install(TARGETS ${LIBRARY_NAME}
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
@@ -42,7 +42,7 @@ index bd8d336..2b09191 100644
#CPack configurtion
SET(CPACK_GENERATOR "DEB" "RPM")
-@@ -369,6 +370,6 @@ endif()
+@@ -395,6 +396,6 @@ endif()
if(STORM_BUILD_TESTS)
add_executable(StormLib_test ${TEST_SRC_FILES})
target_link_libraries(StormLib_test ${LIBRARY_NAME})
@@ -51,5 +51,5 @@ index bd8d336..2b09191 100644
endif()
--
-2.29.2
+2.37.3