summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unadf')
-rw-r--r--app-arch/unadf/unadf-0.7.12-r2.ebuild (renamed from app-arch/unadf/unadf-0.7.12-r1.ebuild)15
1 files changed, 5 insertions, 10 deletions
diff --git a/app-arch/unadf/unadf-0.7.12-r1.ebuild b/app-arch/unadf/unadf-0.7.12-r2.ebuild
index fb1aed5c2ad7..5e358f5bf7e8 100644
--- a/app-arch/unadf/unadf-0.7.12-r1.ebuild
+++ b/app-arch/unadf/unadf-0.7.12-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -10,13 +10,12 @@ MY_PN="adflib"
DESCRIPTION="Extract files from Amiga adf disk images"
HOMEPAGE="http://lclevy.free.fr/adflib/"
SRC_URI="http://lclevy.free.fr/${MY_PN}/${MY_PN}-${PV}.tar.bz2"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~hppa ppc x86 ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="static-libs"
+KEYWORDS="amd64 ~hppa ppc x86 ~x86-linux ~ppc-macos"
-S="${WORKDIR}/${MY_PN}-${PV}"
PATCHES=( "${FILESDIR}"/${PN}-0.7.12-CVE-2016-1243_CVE-2016-1244.patch )
src_prepare() {
@@ -24,11 +23,7 @@ src_prepare() {
eautoreconf
}
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}