summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unlzx/unlzx-1.1.ebuild')
-rw-r--r--app-arch/unlzx/unlzx-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/unlzx/unlzx-1.1.ebuild b/app-arch/unlzx/unlzx-1.1.ebuild
new file mode 100644
index 000000000000..c735acba9581
--- /dev/null
+++ b/app-arch/unlzx/unlzx-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Unarchiver for Amiga LZX archives"
+SRC_URI="ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz.readme"
+HOMEPAGE="ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz.readme"
+
+SLOT="0"
+LICENSE="freedist"
+IUSE=""
+KEYWORDS="alpha amd64 ~hppa ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+
+src_unpack() {
+ mkdir "${S}"
+ gzip -dc "${DISTDIR}"/${PN}.c.gz > "${S}"/unlzx.c
+ cp "${DISTDIR}"/${PN}.c.gz.readme "${S}"/${PN}.c.gz.readme
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o unlzx unlzx.c || die
+}
+
+src_install() {
+ dobin unlzx
+ dodoc unlzx.c.gz.readme
+}