summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/backintime/files')
-rw-r--r--app-backup/backintime/files/backintime-1.0.24-dont-install-license.patch49
-rw-r--r--app-backup/backintime/files/backintime-1.0.24-wrapper.patch64
-rw-r--r--app-backup/backintime/files/backintime-1.0.36-wrapper.patch65
-rw-r--r--app-backup/backintime/files/backintime-1.0.4-fix-configure-warning.diff17
-rw-r--r--app-backup/backintime/files/backintime-1.0.4-kde4-root.desktop11
5 files changed, 206 insertions, 0 deletions
diff --git a/app-backup/backintime/files/backintime-1.0.24-dont-install-license.patch b/app-backup/backintime/files/backintime-1.0.24-dont-install-license.patch
new file mode 100644
index 000000000000..73ba5947e9bf
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.0.24-dont-install-license.patch
@@ -0,0 +1,49 @@
+--- backintime-1.0.4/common/Makefile.template
++++ backintime-1.0.4/common/Makefile.template
+@@ -17,10 +17,6 @@
+ install -d $(DEST)/share/backintime/plugins
+ install --mode=644 plugins/*.py $(DEST)/share/backintime/plugins
+
+- #install copyright file
+- install -d $(DEST)/share/doc/backintime-common
+- install --mode=644 debian_specific/copyright $(DEST)/share/doc/backintime-common
+-
+ #install doc file(s)
+ install -d $(DEST)/share/doc/backintime
+ install --mode=644 ../AUTHORS $(DEST)/share/doc/backintime
+--- backintime-1.0.24/common/Makefile.template
++++ backintime-1.0.24/common/Makefile.template
+@@ -20,7 +20,6 @@
+ #install doc file(s)
+ install -d $(DEST)/share/doc/backintime
+ install --mode=644 ../AUTHORS $(DEST)/share/doc/backintime
+- install --mode=644 ../LICENSE $(DEST)/share/doc/backintime
+ install --mode=644 ../README $(DEST)/share/doc/backintime
+ install --mode=644 ../TRANSLATIONS $(DEST)/share/doc/backintime
+ install --mode=644 ../VERSION $(DEST)/share/doc/backintime
+--- backintime-1.0.4/gnome/Makefile.template
++++ backintime-1.0.4/gnome/Makefile.template
+@@ -15,10 +15,6 @@
+ install -d $(DEST)/share/backintime/plugins
+ install --mode=644 plugins/*.py $(DEST)/share/backintime/plugins
+
+- #install copyright file
+- install -d $(DEST)/share/doc/backintime-gnome
+- install --mode=644 ../common/debian_specific/copyright $(DEST)/share/doc/backintime-gnome
+-
+ #install man file(s)
+ install -d $(DEST)/share/man/man1
+ install --mode=644 man/C/*.gz $(DEST)/share/man/man1
+--- backintime-1.0.4/kde4/Makefile.template
++++ backintime-1.0.4/kde4/Makefile.template
+@@ -19,10 +19,6 @@
+ install -d $(DEST)/bin
+ install backintime-kde4 $(DEST)/bin
+
+- #install copyright file
+- install -d $(DEST)/share/doc/backintime-kde4
+- install --mode=644 ../common/debian_specific/copyright $(DEST)/share/doc/backintime-kde4
+-
+ #install .desktop file(s)
+ install -d $(DEST)/share/applications/kde4
+ install --mode=644 *.desktop $(DEST)/share/applications/kde4
diff --git a/app-backup/backintime/files/backintime-1.0.24-wrapper.patch b/app-backup/backintime/files/backintime-1.0.24-wrapper.patch
new file mode 100644
index 000000000000..fa65098fff85
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.0.24-wrapper.patch
@@ -0,0 +1,64 @@
+--- backintime-1.0.24-r2/common/backintime
++++ backintime-1.0.24-r2/common/backintime
+@@ -17,15 +17,14 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f backintime.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/common"
+-fi
++APP_PATH="/usr/share/backintime/common"
+
+ #starting a new ssh-agent all the time is just a workaround for
+ #https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/841672
+ #normally this should only be necessary if run as cronjob
+ #and the user is not logged in
+-ssh-agent python $APP_PATH/backintime.py "$@"
++if [ "x$SSH_AUTH_SOCK" = "x" ]; then
++ eval "$(ssh-agent)"
++fi
+
++python2 $APP_PATH/backintime.py "$@"
+--- backintime-1.0.24-r2/gnome/backintime-gnome
++++ backintime-1.0.24-r2/gnome/backintime-gnome
+@@ -17,14 +17,13 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f app.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/gnome"
+-fi
++APP_PATH="/usr/share/backintime/gnome"
+
+ #starting a new ssh-agent all the time is just a workaround for
+ #https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/841672
+ #normally we don't need to start ssh-agent for backintime-gnome
+-ssh-agent python ${APP_PATH}/app.py "$@"
++if [ "x$SSH_AUTH_SOCK" = "x" ]; then
++ eval "$(ssh-agent)"
++fi
+
++python2 ${APP_PATH}/app.py "$@"
+--- backintime-1.0.24-r2/kde4/backintime-kde4
++++ backintime-1.0.24-r2/kde4/backintime-kde4
+@@ -17,11 +17,10 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f app.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/kde4"
++APP_PATH="/usr/share/backintime/kde4"
++#https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/841672
++if [ "x$SSH_AUTH_SOCK" = "x" ]; then
++ eval "$(ssh-agent)"
+ fi
+
+-python ${APP_PATH}/app.py "$@"
+-
++python2 ${APP_PATH}/app.py "$@"
diff --git a/app-backup/backintime/files/backintime-1.0.36-wrapper.patch b/app-backup/backintime/files/backintime-1.0.36-wrapper.patch
new file mode 100644
index 000000000000..a0b01245fe1f
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.0.36-wrapper.patch
@@ -0,0 +1,65 @@
+--- backintime-1.0.24-r2/common/backintime
++++ backintime-1.0.24-r2/common/backintime
+@@ -17,15 +17,14 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f backintime.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/common"
+-fi
++APP_PATH="/usr/share/backintime/common"
+
+ #starting a new ssh-agent all the time is just a workaround for
+ #https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/841672
+ #normally this should only be necessary if run as cronjob
+ #and the user is not logged in
+-ssh-agent python $APP_PATH/backintime.py "$@"
++if [ "x$SSH_AUTH_SOCK" = "x" ]; then
++ eval "$(ssh-agent)"
++fi
+
++python2 $APP_PATH/backintime.py "$@"
+--- backintime-1.0.24-r2/gnome/backintime-gnome
++++ backintime-1.0.24-r2/gnome/backintime-gnome
+@@ -17,14 +17,13 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f app.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/gnome"
+-fi
++APP_PATH="/usr/share/backintime/gnome"
+
+ #starting a new ssh-agent all the time is just a workaround for
+ #https://bugs.launchpad.net/ubuntu/+source/openssh/+bug/841672
+ #normally we don't need to start ssh-agent for backintime-gnome
+-ssh-agent python ${APP_PATH}/app.py "$@"
++if [ "x$SSH_AUTH_SOCK" = "x" ]; then
++ eval "$(ssh-agent)"
++fi
+
++python2 ${APP_PATH}/app.py "$@"
+--- backintime-1.0.24-r2/kde4/backintime-kde4
++++ backintime-1.0.24-r2/kde4/backintime-kde4
+@@ -17,15 +17,10 @@
+ # with this program; if not, write to the Free Software Foundation, Inc.,
+ # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if [ -f app.py ]; then
+- APP_PATH="."
+-else
+- APP_PATH="/usr/share/backintime/kde4"
+-fi
++APP_PATH="/usr/share/backintime/kde4"
+
+ if [ "x$SSH_AUTH_SOCK" = "x" ]; then
+ eval "$(ssh-agent)"
+ fi
+
+-python ${APP_PATH}/app.py "$@"
+-
++python2 ${APP_PATH}/app.py "$@"
diff --git a/app-backup/backintime/files/backintime-1.0.4-fix-configure-warning.diff b/app-backup/backintime/files/backintime-1.0.4-fix-configure-warning.diff
new file mode 100644
index 000000000000..40831b400f7a
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.0.4-fix-configure-warning.diff
@@ -0,0 +1,17 @@
+diff -Naur backintime-1.0.4.orig/kde4/configure backintime-1.0.4/kde4/configure
+--- backintime-1.0.4.orig/kde4/configure 2010-11-08 14:36:52.000000000 +0100
++++ backintime-1.0.4/kde4/configure 2010-11-08 14:42:18.000000000 +0100
+@@ -16,13 +16,6 @@
+ fi
+ fi
+
+-#check for kdesudo (if not use kdesu)
+-if [ -z `which kdesudo` ]; then
+- mv backintime-kde4-root.desktop.kdesudo backintime-kde4-root.desktop
+-else
+- mv backintime-kde4-root.desktop.kdesu backintime-kde4-root.desktop
+-fi
+-
+ cp Makefile.template Makefile
+
+ echo "All OK. Now run:"
diff --git a/app-backup/backintime/files/backintime-1.0.4-kde4-root.desktop b/app-backup/backintime/files/backintime-1.0.4-kde4-root.desktop
new file mode 100644
index 000000000000..54d340efcd46
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.0.4-kde4-root.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Back In Time (root)
+Exec=kdesu -c backintime-kde4
+Icon=document-save
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+StartupNotify=true
+Categories=Qt;KDE;System;
+Comment=Simple backup system
+Comment[sl]=Enostaven sistem ustvarjanja varnostnih kopij