summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/consul-backinator/consul-backinator-1.6.5.ebuild')
-rw-r--r--app-backup/consul-backinator/consul-backinator-1.6.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-backup/consul-backinator/consul-backinator-1.6.5.ebuild b/app-backup/consul-backinator/consul-backinator-1.6.5.ebuild
new file mode 100644
index 000000000000..d74bd040c727
--- /dev/null
+++ b/app-backup/consul-backinator/consul-backinator-1.6.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/myENA/consul-backinator
+RESTRICT="strip"
+
+DESCRIPTION="consul backup and restore utility"
+HOMEPAGE="https://github.com/myENA/consul-backinator"
+SRC_URI="https://github.com/myENA/consul-backinator/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-lang/go:="
+
+src_prepare() {
+ default
+ mv ../vendor .
+ echo module ${EGO_PN} > go.mod || die "Unable to create go.mod"
+}
+
+src_compile() {
+ CGO_ENABLED=0 go build -mod vendor -o "${PN}" -v -x \
+ -ldflags="-X main.appVersion=${PV} -s -w" || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.md
+}