summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/cpdup/files')
-rw-r--r--app-backup/cpdup/files/Makefile.linux13
-rw-r--r--app-backup/cpdup/files/cpdup-1.11-unused.patch14
2 files changed, 27 insertions, 0 deletions
diff --git a/app-backup/cpdup/files/Makefile.linux b/app-backup/cpdup/files/Makefile.linux
new file mode 100644
index 000000000000..3e18e4e0b218
--- /dev/null
+++ b/app-backup/cpdup/files/Makefile.linux
@@ -0,0 +1,13 @@
+OBJS = cpdup.o fsmid.o hclink.o hcproto.o misc.o
+
+CFLAGS += -D__cpdup_unused="__attribute__ ((unused))" -D_GNU_SOURCE -D__USE_FILE_OFFSET64 -DNOMD5
+
+ifndef NOPTHREADS
+CFLAGS += -DUSE_PTHREADS=1 -pthread
+endif
+
+all: $(OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o cpdup
+
+.c.o:
+ $(CC) $(CFLAGS) -c -o $@ $<
diff --git a/app-backup/cpdup/files/cpdup-1.11-unused.patch b/app-backup/cpdup/files/cpdup-1.11-unused.patch
new file mode 100644
index 000000000000..1757cb441adc
--- /dev/null
+++ b/app-backup/cpdup/files/cpdup-1.11-unused.patch
@@ -0,0 +1,14 @@
+--- cpdup.c.orig 2009-02-05 12:22:10.000000000 +0100
++++ cpdup.c 2009-02-05 12:23:23.000000000 +0100
+@@ -1543,7 +1543,11 @@
+ */
+
+ static int
++#ifdef _ST_FLAGS_PRESENT_
+ xrename(const char *src, const char *dst, u_long flags)
++#else
++xrename(const char *src, const char *dst, u_long flags __unused)
++#endif
+ {
+ int r;
+