summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/holland-backup-sqlite')
-rw-r--r--app-backup/holland-backup-sqlite/Manifest1
-rw-r--r--app-backup/holland-backup-sqlite/holland-backup-sqlite-1.0.10.ebuild40
-rw-r--r--app-backup/holland-backup-sqlite/metadata.xml10
3 files changed, 51 insertions, 0 deletions
diff --git a/app-backup/holland-backup-sqlite/Manifest b/app-backup/holland-backup-sqlite/Manifest
new file mode 100644
index 000000000000..a4d8dca18b99
--- /dev/null
+++ b/app-backup/holland-backup-sqlite/Manifest
@@ -0,0 +1 @@
+DIST holland-1.0.10.tar.gz 449334 SHA256 c893be3dc77126125334dfa9eec404d7608a78a2bf88ec1d7ddc12ad7f7ed8d1 SHA512 5183ec73012edcaba50ef5cc9b892480d5f60301d01d17bd96c5490bd8e6ae42bd21abb6084e6665317b8025489981a02293cd583964f01e86459609b93e918f WHIRLPOOL fa8934c635f4347ffc6a327f6135d61ca26805d727fe4caca32ba9c23224062492553182e24d15fc59177787241903dd3409396c176fab2d55c34e9dcc5668e3
diff --git a/app-backup/holland-backup-sqlite/holland-backup-sqlite-1.0.10.ebuild b/app-backup/holland-backup-sqlite/holland-backup-sqlite-1.0.10.ebuild
new file mode 100644
index 000000000000..0aa6d6274a28
--- /dev/null
+++ b/app-backup/holland-backup-sqlite/holland-backup-sqlite-1.0.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Holland sqlite Plugin"
+HOMEPAGE="http://www.hollandbackup.org/"
+
+MY_P="${P%%-*}-${P##*-}"
+
+SRC_URI="http://hollandbackup.org/releases/stable/${PV%.*}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="~app-backup/holland-lib-common-${PV}[${PYTHON_USEDEP}]"
+PDEPEND="~app-backup/holland-${PV}[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/plugins/${PN//-/.}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ keepdir /etc/holland
+ keepdir /etc/holland/backupsets
+ keepdir /etc/holland/providers
+
+ insinto /etc/holland/backupsets
+ doins "${S}"/../../config/backupsets/examples/${PN##*-}.conf
+
+ insinto /etc/holland/providers
+ doins "${S}"/../../config/providers/${PN##*-}.conf
+}
diff --git a/app-backup/holland-backup-sqlite/metadata.xml b/app-backup/holland-backup-sqlite/metadata.xml
new file mode 100644
index 000000000000..02be8c5eb78f
--- /dev/null
+++ b/app-backup/holland-backup-sqlite/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>