summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/pdumpfs')
-rw-r--r--app-backup/pdumpfs/Manifest1
-rw-r--r--app-backup/pdumpfs/files/pdumpfs-in.patch40
-rw-r--r--app-backup/pdumpfs/files/pdumpfs-test.patch12
-rw-r--r--app-backup/pdumpfs/metadata.xml20
-rw-r--r--app-backup/pdumpfs/pdumpfs-1.3-r2.ebuild48
5 files changed, 121 insertions, 0 deletions
diff --git a/app-backup/pdumpfs/Manifest b/app-backup/pdumpfs/Manifest
new file mode 100644
index 000000000000..5e782eddd018
--- /dev/null
+++ b/app-backup/pdumpfs/Manifest
@@ -0,0 +1 @@
+DIST pdumpfs-1.3.tar.gz 68210 SHA256 5f50158517f263370d59f6c794a1d45e947bb8c17be23e18a8f293ee13557377 SHA512 1299676982f1981aa55f0601f361ec24ac119067f5ecbbeebcf9f41ccd69df2f18a07ae5a6e77f30ca7606ee49ecfa516d6066a07c1edbb4d4796f34f02508c3 WHIRLPOOL 255ac184759f29b416315f47d4d9ffd5b6c84e6ee28192ce47601937dc05fd48db5f59e30e6d4f4c4c789e4bef0c4ee81dff76cf60bbe338560af42ae1278bf4
diff --git a/app-backup/pdumpfs/files/pdumpfs-in.patch b/app-backup/pdumpfs/files/pdumpfs-in.patch
new file mode 100644
index 000000000000..cddfb995918a
--- /dev/null
+++ b/app-backup/pdumpfs/files/pdumpfs-in.patch
@@ -0,0 +1,40 @@
+patch by proxy maintainer, P. Healy, April 2015
+# Bug 509960
+--- pdumpfs.in_orig 2004-12-21 02:43:12.000000000 +0000
++++ pdumpfs.in 2015-04-01 10:58:22.671131947 +0100
+@@ -48,7 +48,7 @@
+ #
+
+ require 'find'
+-require 'ftools'
++require 'fileutils'
+ require 'getoptlong'
+ require 'date'
+
+@@ -868,7 +868,7 @@
+ today = File.join(dest, datedir(start_time), base)
+
+ File.umask(0077)
+- File.mkpath(today) unless @dry_run
++ FileUtils.mkpath(today) unless @dry_run
+ if latest
+ update_snapshot(src, latest, today)
+ else
+@@ -1018,7 +1018,7 @@
+
+ case type
+ when "directory"
+- File.mkpath(today)
++ FileUtils.mkpath(today)
+ when "unchanged"
+ File.force_link(latest, today)
+ when "updated"
+@@ -1089,7 +1089,7 @@
+
+ case type
+ when "directory"
+- File.mkpath(t)
++ FileUtils.mkpath(t)
+ when "new_file"
+ copy(s, t)
+ when "symlink"
diff --git a/app-backup/pdumpfs/files/pdumpfs-test.patch b/app-backup/pdumpfs/files/pdumpfs-test.patch
new file mode 100644
index 000000000000..e81e8b0f2d8a
--- /dev/null
+++ b/app-backup/pdumpfs/files/pdumpfs-test.patch
@@ -0,0 +1,12 @@
+patch by proxy maintainer, P. Healy, April 2015
+# Bug 509960
+--- tests/pdumpfs-test_orig 2004-08-10 07:54:28.000000000 +0100
++++ tests/pdumpfs-test 2015-04-01 11:24:35.948633870 +0100
+@@ -17,6 +17,7 @@
+
+ ../pdumpfs src dest > tmp.log || exit 1
+ diff -r src dest/$today/src || exit 1
++mkdir -p dest/$yesterday && rmdir dest/$yesterday
+ mv dest/$today dest/$yesterday
+
+ echo update > src/foo
diff --git a/app-backup/pdumpfs/metadata.xml b/app-backup/pdumpfs/metadata.xml
new file mode 100644
index 000000000000..3717738d65d6
--- /dev/null
+++ b/app-backup/pdumpfs/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>lmiphay@gmail.com</email>
+ <name>Paul Healy</name>
+ <description>Active Maintainer, Assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+<longdescription>
+pdumpfs is a simple daily backup system similar to Plan9's dumpfs which
+preserves every daily snapshot. pdumpfs is written in Ruby. You can access
+the past snapshots at any time for retrieving a certain day's file. Let's
+backup your home directory with pdumpfs!
+</longdescription>
+</pkgmetadata>
diff --git a/app-backup/pdumpfs/pdumpfs-1.3-r2.ebuild b/app-backup/pdumpfs/pdumpfs-1.3-r2.ebuild
new file mode 100644
index 000000000000..3a7ca1039d77
--- /dev/null
+++ b/app-backup/pdumpfs/pdumpfs-1.3-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="a daily backup system similar to Plan9's dumpfs"
+HOMEPAGE="http://0xcc.net/pdumpfs/"
+SRC_URI="http://0xcc.net/pdumpfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="linguas_ja"
+
+DEPEND=">=dev-lang/ruby-2.0.0_p598"
+
+src_prepare() {
+ # Bug #509960
+ epatch "${FILESDIR}/${PN}-in.patch" \
+ "${FILESDIR}/${PN}-test.patch"
+}
+
+src_compile() {
+ emake pdumpfs
+}
+
+src_test() {
+ # RUBYOPT=-rauto_gem without rubygems installed will cause ruby to fail, bug #158455 and #163473.
+ export RUBYOPT="${GENTOO_RUBYOPT}"
+ emake check
+}
+
+src_install() {
+ dobin pdumpfs
+
+ doman man/man8/pdumpfs.8
+ dohtml -r doc/*
+
+ if use linguas_ja; then
+ insinto /usr/share/man/ja/man8
+ doins man/ja/man8/pdumpfs.8
+ fi
+
+ dodoc ChangeLog README
+}