summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/untangle-https-backup/untangle-https-backup-0.1.0-r2.ebuild')
-rw-r--r--app-backup/untangle-https-backup/untangle-https-backup-0.1.0-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-backup/untangle-https-backup/untangle-https-backup-0.1.0-r2.ebuild b/app-backup/untangle-https-backup/untangle-https-backup-0.1.0-r2.ebuild
new file mode 100644
index 000000000000..123e746bccf5
--- /dev/null
+++ b/app-backup/untangle-https-backup/untangle-https-backup-0.1.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 python3_11 python3_12 )
+PYTHON_REQ_USE="ssl(+)"
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Back up Untangle configurations via the web admin UI"
+HOMEPAGE="https://michael.orlitzky.com/code/untangle-https-backup.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_install() {
+ distutils-r1_src_install
+ doman "doc/man8/${PN}.8"
+ dodoc "doc/${PN}.example.ini"
+}