summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/bonnie++/files')
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.93c-64bit.patch15
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch46
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch46
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.95-homepage.patch12
-rw-r--r--app-benchmarks/bonnie++/files/bonnie++-1.96-compile-flags.patch17
5 files changed, 136 insertions, 0 deletions
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.93c-64bit.patch b/app-benchmarks/bonnie++/files/bonnie++-1.93c-64bit.patch
new file mode 100644
index 000000000000..2af76d8f8c80
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.93c-64bit.patch
@@ -0,0 +1,15 @@
+--- getc_putc.cpp.old 2004-09-15 02:37:21.500489552 +0200
++++ getc_putc.cpp 2004-09-15 02:40:58.623481840 +0200
+@@ -165,7 +165,11 @@
+ int size = 0, wrote;
+ while(size < file_size)
+ {
+- wrote = write(FILE_FD, buf, min(sizeof(buf), (unsigned int)file_size - size));
++ //wrote = write(FILE_FD, buf, min(sizeof(buf), (unsigned int)file_size - size));
++ /*
++ * gcc doesn't like above line. ? : should do the job as good as min()...
++ */
++ wrote = write(FILE_FD, buf, (sizeof(buf) < (file_size - size) ? (sizeof(buf)):(file_size - size)));
+ if(wrote < 0)
+ {
+ fprintf(stderr, "Can't extend file - disk full?\n");
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch b/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch
new file mode 100644
index 000000000000..2afe02b496bd
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.93c-missing_include.patch
@@ -0,0 +1,46 @@
+diff -Naur bonnie++-1.93c.orig/bon_csv2html.cpp bonnie++-1.93c/bon_csv2html.cpp
+--- bonnie++-1.93c.orig/bon_csv2html.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/bon_csv2html.cpp 2008-05-02 14:13:57.000000000 +0200
+@@ -3,6 +3,7 @@
+ #include <vector>
+ #include <string.h>
+ #include <math.h>
++#include <stdlib.h>
+
+ // Maximum number of items expected on a csv line
+ #define MAX_ITEMS 48
+diff -Naur bonnie++-1.93c.orig/getc_putc.cpp bonnie++-1.93c/getc_putc.cpp
+--- bonnie++-1.93c.orig/getc_putc.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc.cpp 2008-05-02 14:19:15.000000000 +0200
+@@ -12,6 +12,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include <vector>
+
+ #include "duration.h"
+diff -Naur bonnie++-1.93c.orig/getc_putc_helper.cpp bonnie++-1.93c/getc_putc_helper.cpp
+--- bonnie++-1.93c.orig/getc_putc_helper.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc_helper.cpp 2008-05-02 14:19:57.000000000 +0200
+@@ -7,6 +7,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include "duration.h"
+ #include <vector>
+ #include "getc_putc.h"
+diff -Naur bonnie++-1.93c.orig/zcav.cpp bonnie++-1.93c/zcav.cpp
+--- bonnie++-1.93c.orig/zcav.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/zcav.cpp 2008-05-02 14:20:42.000000000 +0200
+@@ -9,6 +9,9 @@
+ #include "getopt.h"
+ #endif
+
++#include <stdlib.h>
++#include <string.h>
++
+ #define TOO_MANY_LOOPS 100
+
+ void usage()
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch b/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch
new file mode 100644
index 000000000000..2afe02b496bd
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.94-missing_include.patch
@@ -0,0 +1,46 @@
+diff -Naur bonnie++-1.93c.orig/bon_csv2html.cpp bonnie++-1.93c/bon_csv2html.cpp
+--- bonnie++-1.93c.orig/bon_csv2html.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/bon_csv2html.cpp 2008-05-02 14:13:57.000000000 +0200
+@@ -3,6 +3,7 @@
+ #include <vector>
+ #include <string.h>
+ #include <math.h>
++#include <stdlib.h>
+
+ // Maximum number of items expected on a csv line
+ #define MAX_ITEMS 48
+diff -Naur bonnie++-1.93c.orig/getc_putc.cpp bonnie++-1.93c/getc_putc.cpp
+--- bonnie++-1.93c.orig/getc_putc.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc.cpp 2008-05-02 14:19:15.000000000 +0200
+@@ -12,6 +12,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include <vector>
+
+ #include "duration.h"
+diff -Naur bonnie++-1.93c.orig/getc_putc_helper.cpp bonnie++-1.93c/getc_putc_helper.cpp
+--- bonnie++-1.93c.orig/getc_putc_helper.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/getc_putc_helper.cpp 2008-05-02 14:19:57.000000000 +0200
+@@ -7,6 +7,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+ #include "duration.h"
+ #include <vector>
+ #include "getc_putc.h"
+diff -Naur bonnie++-1.93c.orig/zcav.cpp bonnie++-1.93c/zcav.cpp
+--- bonnie++-1.93c.orig/zcav.cpp 2008-05-02 14:12:19.000000000 +0200
++++ bonnie++-1.93c/zcav.cpp 2008-05-02 14:20:42.000000000 +0200
+@@ -9,6 +9,9 @@
+ #include "getopt.h"
+ #endif
+
++#include <stdlib.h>
++#include <string.h>
++
+ #define TOO_MANY_LOOPS 100
+
+ void usage()
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.95-homepage.patch b/app-benchmarks/bonnie++/files/bonnie++-1.95-homepage.patch
new file mode 100644
index 000000000000..114d4143453b
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.95-homepage.patch
@@ -0,0 +1,12 @@
+diff -Nu -Nu -uarN bonnie++-1.93c.orig/bonnie++.8 bonnie++-1.93c/bonnie++.8
+--- bonnie++-1.93c.orig/bonnie++.8 2008-05-27 09:49:18.000000000 +0200
++++ bonnie++-1.93c/bonnie++.8 2008-05-27 09:51:50.000000000 +0200
+@@ -32,7 +32,7 @@
+ INN.
+ .P
+ All the details of the tests performed by Bonnie++ are contained in the file
+-.BR /usr/share/doc/bonnie++/readme.html
++.BR /usr/share/doc/bonnie++-1.95/html/readme.html
+
+ .SH "OPTIONS"
+ For Bonnie++ every option is of the form of a hyphen followed by a letter and
diff --git a/app-benchmarks/bonnie++/files/bonnie++-1.96-compile-flags.patch b/app-benchmarks/bonnie++/files/bonnie++-1.96-compile-flags.patch
new file mode 100644
index 000000000000..05821f977ecc
--- /dev/null
+++ b/app-benchmarks/bonnie++/files/bonnie++-1.96-compile-flags.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile.in b/Makefile.in
+index 4f14819..1092891 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -9,9 +9,9 @@ prefix=@prefix@
+ eprefix=@exec_prefix@
+ #MORE_WARNINGS=-Weffc++
+ WFLAGS=-Wall -W -Wshadow -Wpointer-arith -Wwrite-strings -pedantic -ffor-scope -Wcast-align -Wsign-compare -Wpointer-arith -Wwrite-strings -Wformat-security -Wswitch-enum -Winit-self $(MORE_WARNINGS)
+-CFLAGS=-O2 @debug@ -DNDEBUG $(WFLAGS) $(MORECFLAGS)
+-CXX=@CXX@ $(CFLAGS)
+-LINK=@CXX@
++CXXFLAGS += @debug@ -DNDEBUG $(WFLAGS)
++CXX=@CXX@ $(CXXFLAGS)
++LINK=@CXX@ $(LDFLAGS)
+ THREAD_LFLAGS=@thread_ldflags@
+
+ INSTALL=@INSTALL@