summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/bonnie')
-rw-r--r--app-benchmarks/bonnie/bonnie-2.0.6-r2.ebuild33
-rw-r--r--app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild34
-rw-r--r--app-benchmarks/bonnie/files/Makefile.patch16
-rw-r--r--app-benchmarks/bonnie/files/bonnie-2.0.6-clang16.patch8
-rw-r--r--app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch10
-rw-r--r--app-benchmarks/bonnie/files/bonnie-2.0.6-man.patch8
-rw-r--r--app-benchmarks/bonnie/files/bonnie_man.patch16
7 files changed, 53 insertions, 72 deletions
diff --git a/app-benchmarks/bonnie/bonnie-2.0.6-r2.ebuild b/app-benchmarks/bonnie/bonnie-2.0.6-r2.ebuild
deleted file mode 100644
index 9c683b9e65ac..000000000000
--- a/app-benchmarks/bonnie/bonnie-2.0.6-r2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Performance Test of Filesystem I/O using standard C library calls"
-HOMEPAGE="http://www.textuality.com/bonnie/"
-SRC_URI="http://www.textuality.com/bonnie/bonnie.tar.gz -> ${P}.tar.gz"
-
-LICENSE="bonnie"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-
-S=${WORKDIR}
-
-PATCHES=(
- "${FILESDIR}"/bonnie_man.patch
- "${FILESDIR}"/Makefile.patch
- "${FILESDIR}"/${P}-includes.patch
-)
-
-src_configure() {
- tc-export CC
-}
-
-src_install() {
- newbin Bonnie bonnie
- doman bonnie.1
- dodoc Instructions
-}
diff --git a/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild b/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild
new file mode 100644
index 000000000000..075d22f8e1b7
--- /dev/null
+++ b/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Performance Test of Filesystem I/O using standard C library calls"
+HOMEPAGE="https://www.textuality.com/bonnie/"
+SRC_URI="https://www.textuality.com/bonnie/bonnie.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="bonnie"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-includes.patch
+ "${FILESDIR}"/${P}-man.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_compile() {
+ tc-export CC
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
+ emake -f /dev/null Bonnie
+}
+
+src_install() {
+ newbin Bonnie bonnie
+ doman bonnie.1
+ dodoc Instructions
+}
diff --git a/app-benchmarks/bonnie/files/Makefile.patch b/app-benchmarks/bonnie/files/Makefile.patch
deleted file mode 100644
index d803bd077ced..000000000000
--- a/app-benchmarks/bonnie/files/Makefile.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,11 +1,9 @@
--CFLAGS = -O $(SYSFLAGS)
--
- bsd:
- @echo 'Options are "make bsd" and "make SysV" - the default is "bsd".'
- @echo 'If you get messages about missing functions, try "make SysV."'
-- make Bonnie
-+ $(MAKE) Bonnie
-
- SysV:
-- make Bonnie 'SYSFLAGS=-DSysV'
-+ $(MAKE) Bonnie 'SYSFLAGS=-DSysV'
-
- Bonnie:
diff --git a/app-benchmarks/bonnie/files/bonnie-2.0.6-clang16.patch b/app-benchmarks/bonnie/files/bonnie-2.0.6-clang16.patch
new file mode 100644
index 000000000000..d1a3a36fa4f2
--- /dev/null
+++ b/app-benchmarks/bonnie/files/bonnie-2.0.6-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/870559
+--- a/Bonnie.c
++++ b/Bonnie.c
+@@ -93,3 +93,3 @@
+
+-main(
++int main(
+ int argc,
diff --git a/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch b/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch
index cfefe953c6f1..8bec1e2ab04d 100644
--- a/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch
+++ b/app-benchmarks/bonnie/files/bonnie-2.0.6-includes.patch
@@ -1,13 +1,9 @@
---- a/Bonnie.c 1996-08-28 18:23:49.000000000 +0200
-+++ b/Bonnie.c 2010-10-12 20:15:26.000000000 +0200
-@@ -29,6 +29,10 @@
- #include <fcntl.h>
- #include <sys/types.h>
+--- a/Bonnie.c
++++ b/Bonnie.c
+@@ -31,2 +31,6 @@
#include <sys/time.h>
+#include <time.h>
+#include <string.h>
+#include <stdlib.h>
+#include <sys/wait.h>
#if defined(SysV)
- #include <limits.h>
- #include <sys/times.h>
diff --git a/app-benchmarks/bonnie/files/bonnie-2.0.6-man.patch b/app-benchmarks/bonnie/files/bonnie-2.0.6-man.patch
new file mode 100644
index 000000000000..d492ebd7c922
--- /dev/null
+++ b/app-benchmarks/bonnie/files/bonnie-2.0.6-man.patch
@@ -0,0 +1,8 @@
+--- a/bonnie.1
++++ b/bonnie.1
+@@ -63 +63 @@
+-.TH Bonnie 1 "2.0.6" Textuality
++.TH bonnie 1 "2.0.6" Textuality
+@@ -67 +67 @@
+-.B Bonnie
++.B bonnie
diff --git a/app-benchmarks/bonnie/files/bonnie_man.patch b/app-benchmarks/bonnie/files/bonnie_man.patch
deleted file mode 100644
index e4b2fe0a12e3..000000000000
--- a/app-benchmarks/bonnie/files/bonnie_man.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/bonnie.1 2003-01-07 14:19:29.000000000 -0600
-+++ b/bonnie.1 2003-01-07 14:20:19.000000000 -0600
-@@ -60,11 +60,11 @@
- .fi
- .in
- ..
--.TH Bonnie 1 "2.0.6" Textuality
-+.TH bonnie 1 "2.0.6" Textuality
- .SH NAME
- Bonnie - File system benchmark
- .SH "SYNOPSIS"
--.B Bonnie
-+.B bonnie
- .RI "[-d\ scratch-dir]"
- .RI "[-html]"
- .RI "[-m\ machine-label]"