summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/cpuburn')
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r5.ebuild (renamed from app-benchmarks/cpuburn/cpuburn-1.4a-r3.ebuild)9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r3.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r5.ebuild
index 0026ef70327e..37e9bf82a74d 100644
--- a/app-benchmarks/cpuburn/cpuburn-1.4a-r3.ebuild
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a-r5.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_PV="${PV/./_}"
+inherit flag-o-matic
+
DESCRIPTION="CPU testing utilities in optimized assembler for maximum loading"
HOMEPAGE="https://web.archive.org/web/20110623074500/pages.sbcglobal.net/redelm/"
SRC_URI="https://dev.gentoo.org/~conikost/files/${PN}_${MY_PV}_tar.gz -> ${P}.tar.gz"
@@ -39,6 +41,9 @@ src_prepare() {
}
src_compile() {
+ # See bug 913410 for more information.
+ append-ldflags -z notext
+
if use arm; then
cd "${S}"/ARM || die
fi