summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/xbiso/xbiso-0.6.1-r3.ebuild')
-rw-r--r--app-cdr/xbiso/xbiso-0.6.1-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild b/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild
new file mode 100644
index 000000000000..421a28f52baf
--- /dev/null
+++ b/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="Xbox xdvdfs ISO extraction utility"
+HOMEPAGE="https://sourceforge.net/projects/xbiso/"
+SRC_URI="mirror://sourceforge/xbiso/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ftp"
+
+RDEPEND="ftp? ( <net-libs/ftplib-4 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+ sed -i -e 's:C) $(CFLAGS):C) $(LDFLAGS) $(CFLAGS):' Makefile.in || die #337769
+ eapply "${FILESDIR}/${P}-libs.patch"
+ mv configure.in configure.ac || die #426262
+ eautoreconf
+}
+
+src_configure() {
+ # for this package, interix behaves the same as BSD
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_BSD
+
+ econf \
+ $(use_enable ftp)
+}
+
+src_install() {
+ dobin xbiso
+ dodoc CHANGELOG README
+}