summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/buildah/files/softcode-strip-upstream-pr-5446.patch')
-rw-r--r--app-containers/buildah/files/softcode-strip-upstream-pr-5446.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-containers/buildah/files/softcode-strip-upstream-pr-5446.patch b/app-containers/buildah/files/softcode-strip-upstream-pr-5446.patch
new file mode 100644
index 000000000000..0ca0a6602a7d
--- /dev/null
+++ b/app-containers/buildah/files/softcode-strip-upstream-pr-5446.patch
@@ -0,0 +1,29 @@
+commit 2cd31a0698bea846366e8e153619a108484a1a2a
+Author: Rahil Bhimjiani <me@rahil.rocks>
+Date: Mon Apr 1 09:25:21 2024 +0530
+
+ Makefile: softcode `strip`, use it from env var
+
+ Signed-off-by: Rahil Bhimjiani <me@rahil.rocks>
+
+diff --git a/Makefile b/Makefile
+index 7d27a4153..3a955c85a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -17,6 +17,7 @@ BUILDAH := buildah
+ SELINUXOPT ?= $(shell test -x /usr/sbin/selinuxenabled && selinuxenabled && echo -Z)
+ SELINUXTYPE=container_runtime_exec_t
+ AS ?= as
++STRIP ?= strip
+
+ GO := go
+ GO_LDFLAGS := $(shell if $(GO) version|grep -q gccgo; then echo "-gccgoflags"; else echo "-ldflags"; fi)
+@@ -87,7 +88,7 @@ internal/mkcw/embed/entrypoint_amd64.gz: internal/mkcw/embed/entrypoint_amd64
+ internal/mkcw/embed/entrypoint_amd64: internal/mkcw/embed/entrypoint_amd64.s
+ $(AS) -o $(patsubst %.s,%.o,$^) $^
+ $(LD) -o $@ $(patsubst %.s,%.o,$^)
+- strip $@
++ $(STRIP) $@
+ endif
+
+