summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/cosign/cosign-2.2.0.ebuild')
-rw-r--r--app-containers/cosign/cosign-2.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-containers/cosign/cosign-2.2.0.ebuild b/app-containers/cosign/cosign-2.2.0.ebuild
new file mode 100644
index 000000000000..54a6b816281f
--- /dev/null
+++ b/app-containers/cosign/cosign-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_HASH=546f1c5b91ef58d6b034a402d0211d980184a0e5
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH} \
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+dodoc CHANGELOG.md
+}