summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/adcli/adcli-0.9.2.ebuild')
-rw-r--r--app-crypt/adcli/adcli-0.9.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/adcli/adcli-0.9.2.ebuild b/app-crypt/adcli/adcli-0.9.2.ebuild
new file mode 100644
index 000000000000..37fb304f40a8
--- /dev/null
+++ b/app-crypt/adcli/adcli-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tool for performing actions on an Active Directory domain"
+HOMEPAGE="https://www.freedesktop.org/software/realmd/adcli/adcli.html"
+SRC_URI="https://gitlab.freedesktop.org/realmd/adcli/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ app-crypt/mit-krb5
+ net-nds/openldap:=[sasl]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ app-text/docbook-xml-dtd:4.3
+ app-text/xmlto
+ dev-libs/libxslt
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc)
+}