summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/aescrypt/aescrypt-3.0.6b.ebuild')
-rw-r--r--app-crypt/aescrypt/aescrypt-3.0.6b.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild b/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild
new file mode 100644
index 000000000000..1f5e2c60f1f8
--- /dev/null
+++ b/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Advanced file encryption using AES"
+HOMEPAGE="http://www.aescrypt.com/"
+SRC_URI="https://www.aescrypt.com/download/v3/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ epatch "${FILESDIR}/${P}-iconv.patch"
+}
+
+src_compile() {
+ if use static; then
+ append-cflags "-DDISABLE_ICONV"
+ append-ldflags "-static"
+ fi
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}