summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/asekey/files')
-rw-r--r--app-crypt/asekey/files/asekey-3.7-dont-call-toolchain-cc-directly.patch13
-rw-r--r--app-crypt/asekey/files/asekey-3.7-musl-ushort.patch14
2 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/asekey/files/asekey-3.7-dont-call-toolchain-cc-directly.patch b/app-crypt/asekey/files/asekey-3.7-dont-call-toolchain-cc-directly.patch
new file mode 100644
index 000000000000..ba51ff4dea9f
--- /dev/null
+++ b/app-crypt/asekey/files/asekey-3.7-dont-call-toolchain-cc-directly.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/745291
+
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@
+ DRIVER_DIR=${DESTDIR}/${USBDROPDIR}/ifd-ASEKey.bundle
+ UDEV_DIR=${DESTDIR}/${UDEVDIR}
+
+-CC=${BUILD}-gcc
++CC?=gcc
+
+ SOURCES=usb.c atr.c DriverIO.c CommandTypes.c ReaderCommands.c T1Protocol.c MemoryCards.c InitCardParams.c ifdhandler.c
+
diff --git a/app-crypt/asekey/files/asekey-3.7-musl-ushort.patch b/app-crypt/asekey/files/asekey-3.7-musl-ushort.patch
new file mode 100644
index 000000000000..5893527eff8a
--- /dev/null
+++ b/app-crypt/asekey/files/asekey-3.7-musl-ushort.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/714222
+
+Hack instead of fix because upstream is dead and the typedef is used extensively.
+
+--- a/Ase.h
++++ b/Ase.h
+@@ -24,6 +24,7 @@
+ #include "T1Protocol.h"
+ #include "MemoryCards.h"
+
++typedef unsigned short ushort;
+
+ //#define ASE_DEBUG
+