summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/cfssl/cfssl-1.6.0.ebuild')
-rw-r--r--app-crypt/cfssl/cfssl-1.6.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-crypt/cfssl/cfssl-1.6.0.ebuild b/app-crypt/cfssl/cfssl-1.6.0.ebuild
index 58eda26f63bc..3d244721ab37 100644
--- a/app-crypt/cfssl/cfssl-1.6.0.ebuild
+++ b/app-crypt/cfssl/cfssl-1.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/cloudflare/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0 BSD BSD-1 MIT MPL-2.0"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~arm64"
IUSE="hardened"
RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
@@ -21,6 +21,9 @@ PATCHES=(
)
src_compile() {
+ # bug 905997
+ use elibc_musl && export CGO_CFLAGS="-D_LARGEFILE64_SOURCE"
+
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" emake VERSION="${PV}"
}