summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/efitools/efitools-1.9.2-r1.ebuild')
-rw-r--r--app-crypt/efitools/efitools-1.9.2-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-crypt/efitools/efitools-1.9.2-r1.ebuild b/app-crypt/efitools/efitools-1.9.2-r1.ebuild
index ae06bba83d82..0deba136bb4c 100644
--- a/app-crypt/efitools/efitools-1.9.2-r1.ebuild
+++ b/app-crypt/efitools/efitools-1.9.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git/snaps
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="static"
LIB_DEPEND="dev-libs/openssl:=[static-libs(+)]"
@@ -48,5 +48,9 @@ src_prepare() {
}
src_configure() {
+ # Calls LD directly, doesn't respect LDFLAGS. Low level package anyway.
+ # See bug #908813.
+ filter-lto
+
tc-export AR CC LD NM OBJCOPY PKG_CONFIG
}