summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libsecret/libsecret-0.18.3.ebuild')
-rw-r--r--app-crypt/libsecret/libsecret-0.18.3.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/app-crypt/libsecret/libsecret-0.18.3.ebuild b/app-crypt/libsecret/libsecret-0.18.3.ebuild
deleted file mode 100644
index e2d87f704e63..000000000000
--- a/app-crypt/libsecret/libsecret-0.18.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-VALA_MIN_API_VERSION=0.18
-VALA_USE_DEPEND=vapigen
-
-inherit gnome2 python-any-r1 vala virtualx
-
-DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
-HOMEPAGE="https://live.gnome.org/Libsecret"
-
-LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
-SLOT="0"
-IUSE="+crypt debug +introspection test vala"
-REQUIRED_USE="vala? ( introspection )"
-KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd"
-
-RDEPEND="
- >=dev-libs/glib-2.38:2
- crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
- introspection? ( >=dev-libs/gobject-introspection-1.29 )
-"
-PDEPEND=">=gnome-base/gnome-keyring-3
-"
-# PDEPEND to avoid circular dep (bug #547456)
-# Add ksecrets to PDEPEND when it's added to portage
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.35.0
- sys-devel/gettext
- virtual/pkgconfig
- test? (
- dev-python/mock
- introspection? (
- ${PYTHON_DEPS}
- >=dev-libs/gjs-1.32
- dev-python/pygobject:3 )
- )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog NEWS README"
- gnome2_src_configure \
- --enable-manpages \
- --disable-strict \
- --disable-coverage \
- --disable-static \
- $(use_enable crypt gcrypt) \
- $(use_enable introspection) \
- $(use_enable vala)
-}
-
-src_test() {
- Xemake check
-}