summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/nwipe/nwipe-0.35.ebuild')
-rw-r--r--app-crypt/nwipe/nwipe-0.35.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/nwipe/nwipe-0.35.ebuild b/app-crypt/nwipe/nwipe-0.35.ebuild
new file mode 100644
index 000000000000..d65ee9b2fa41
--- /dev/null
+++ b/app-crypt/nwipe/nwipe-0.35.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Securely erase disks using a variety of recognized methods"
+HOMEPAGE="https://github.com/martijnvanbrummelen/nwipe/"
+SRC_URI="https://github.com/martijnvanbrummelen/nwipe/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libconfig:=
+ sys-block/parted
+ sys-libs/ncurses:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}