summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild')
-rw-r--r--app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
index f350b7c57fac..62fa4d53da7b 100644
--- a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
+++ b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
@@ -1,38 +1,36 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=8
DESCRIPTION="Tables available for ophcrack"
-HOMEPAGE="http://ophcrack.sourceforge.net/"
-SRC_URI="xpfast? ( mirror://sourceforge/ophcrack/tables_xp_free_fast.zip )
- xpsmall? ( mirror://sourceforge/ophcrack/tables_xp_free_small.zip )
- vistafree? ( mirror://sourceforge/ophcrack/tables_vista_free.zip )"
+HOMEPAGE="https://ophcrack.sourceforge.io"
+SRC_URI="
+ xpfast? ( mirror://sourceforge/ophcrack/tables_xp_free_fast.zip )
+ xpsmall? ( mirror://sourceforge/ophcrack/tables_xp_free_small.zip )
+ vistafree? ( mirror://sourceforge/ophcrack/tables_vista_free.zip )"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+xpfast xpsmall +vistafree"
-
REQUIRED_USE="|| ( xpfast xpsmall vistafree )"
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S=${WORKDIR}
+BDEPEND="app-arch/unzip"
src_unpack() {
- for i in ${A};
- do
+ local i table
+ for i in ${A}; do
table=${i#tables_}
table=${table%.zip}
- mkdir "${S}/${table}"
+ mkdir "${S}"/${table} || die
cd $_ || die
unpack "${i}"
done
}
src_install() {
- dodir /usr/share/ophcrack/
- cp -r "${S}"/* "${ED}"/usr/share/ophcrack/ || die
+ insinto /usr/share/ophcrack
+ doins -r .
}