summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild')
-rw-r--r--app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild b/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild
new file mode 100644
index 000000000000..69ef87e14f5b
--- /dev/null
+++ b/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils qt4-r2
+
+MY_P="${P/_/-}"
+QCA_VER="${PV%.*}"
+
+DESCRIPTION="PKCS#11 (smartcard) plugin for QCA"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/download/qca/${QCA_VER}/plugins/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=app-crypt/qca-${QCA_VER}[debug?]
+ >=dev-libs/pkcs11-helper-1.02"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_configure() {
+ # cannot use econf because of non-standard configure script
+ ./configure \
+ --qtdir=/usr \
+ $(use debug && echo "--debug" || echo "--release") \
+ --no-separate-debug-info \
+ || die "configure failed"
+ qt4-r2_src_configure
+}