summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/eblook')
-rw-r--r--app-dicts/eblook/Manifest1
-rw-r--r--app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild34
-rw-r--r--app-dicts/eblook/eblook-1.6.1_p16.ebuild (renamed from app-dicts/eblook/eblook-1.6.1.ebuild)20
-rw-r--r--app-dicts/eblook/files/eblook-1.6.1-LDFLAGS.patch20
-rw-r--r--app-dicts/eblook/files/eblook-1.6.1-clang-16-buildfix.patch11
5 files changed, 61 insertions, 25 deletions
diff --git a/app-dicts/eblook/Manifest b/app-dicts/eblook/Manifest
index a2cc29521e69..fea1fa67e52f 100644
--- a/app-dicts/eblook/Manifest
+++ b/app-dicts/eblook/Manifest
@@ -1 +1,2 @@
DIST eblook-1.6.1.tar.gz 440727 BLAKE2B 313dcc89fea9dbc8dac8c9fda618cf4e39d0cfef4f67ba7cf2ab29e3b1c8dc0559407c1f1c68c9994594b784acb445c6fe988456e14da324bd38c89de23f3ffe SHA512 36f4f383a53a0332a2dec0e40d2743c93d35c9f51a7de2d2706bbc18a4fde215d4e345feb175bebf428c1760cb32e73148fb9b336fcde8c0d8b924ee6ecfd6a4
+DIST eblook_1.6.1-16.debian.tar.xz 92044 BLAKE2B 9a6b19541c910694b0b079cfb4bcb9ae38f4505e25a08f4c17dd7af6cf04a1b5e9a33aadbda7a4c5a8509699b0a5efe4eb5962b6cdd6f63a82105bacad5231a7 SHA512 538956ac54cedae76563bcbc6c8ac7f97be4cdc2d9cc506fc14444dc3a7c9631040a1becf259c1f465b4e875333ffb43d6af5c8102b9fc8b862b7567cafc8d83
diff --git a/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild b/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild
new file mode 100644
index 000000000000..4ef5bb49eb6c
--- /dev/null
+++ b/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Interactive search utility for electronic dictionaries"
+HOMEPAGE="http://openlab.ring.gr.jp/edict/eblook/"
+SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${PN}-$(ver_cut 1-3).tar.gz"
+SRC_URI+=" mirror://debian/pool/main/e/eblook/eblook_$(ver_cut 1-3)-$(ver_cut 5).debian.tar.xz"
+S="${WORKDIR}"/${PN}-$(ver_cut 1-3)
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~riscv x86"
+
+DEPEND=">=dev-libs/eb-3.3.4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+ "${FILESDIR}"/${PN}-1.6.1-clang-16-buildfix.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-eb-conf="${EPREFIX}"/etc/eb.conf
+}
diff --git a/app-dicts/eblook/eblook-1.6.1.ebuild b/app-dicts/eblook/eblook-1.6.1_p16.ebuild
index 0ac5d0edc7d7..f71ec794fa08 100644
--- a/app-dicts/eblook/eblook-1.6.1.ebuild
+++ b/app-dicts/eblook/eblook-1.6.1_p16.ebuild
@@ -1,11 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="Interactive search utility for electronic dictionaries"
HOMEPAGE="http://openlab.ring.gr.jp/edict/eblook/"
-SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${P/_/}.tar.gz"
+SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${PN}-$(ver_cut 1-3).tar.gz"
+SRC_URI+=" mirror://debian/pool/main/e/eblook/eblook_$(ver_cut 1-3)-$(ver_cut 5).debian.tar.xz"
+S="${WORKDIR}"/${PN}-$(ver_cut 1-3)
LICENSE="GPL-2"
SLOT="0"
@@ -14,9 +18,15 @@ KEYWORDS="~amd64 ppc ~riscv x86"
DEPEND=">=dev-libs/eb-3.3.4"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${P%_*}"
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+)
+
+src_prepare() {
+ default
-PATCHES=( "${FILESDIR}"/${P}-LDFLAGS.patch )
+ eautoreconf
+}
src_configure() {
econf --with-eb-conf="${EPREFIX}"/etc/eb.conf
diff --git a/app-dicts/eblook/files/eblook-1.6.1-LDFLAGS.patch b/app-dicts/eblook/files/eblook-1.6.1-LDFLAGS.patch
deleted file mode 100644
index 79bb33dd0292..000000000000
--- a/app-dicts/eblook/files/eblook-1.6.1-LDFLAGS.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -21918,7 +21918,7 @@
- save_LIBS=$LIBS
- CPPFLAGS="$CPPFLAGS $EBCONF_PTHREAD_CPPFLAGS $EBCONF_EBINCS $EBCONF_ZLIBINCS $EBCONF_INTLINCS"
- CFLAGS="$CFLAGS $EBCONF_PTHREAD_CFLAGS"
--LDFLAGS="$LDFAGS $EBCONF_PTHREAD_LDFLAGS"
-+LDFLAGS="$LDFLAGS $EBCONF_PTHREAD_LDFLAGS"
- LIBS="$LIBS $EBCONF_EBLIBS $EBCONF_ZLIBLIBS $EBCONF_INTLLIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
-@@ -21981,7 +21981,7 @@
- sysconfdir=$sysconfdir
- CPPFLAGS="$CPPFLAGS $EBCONF_PTHREAD_CPPFLAGS $EBCONF_EBINCS $EBCONF_ZLIBINCS $EBCONF_INTLINCS"
- CFLAGS="$CFLAGS $EBCONF_PTHREAD_CFLAGS"
--LDFLAGS="$LDFAGS $EBCONF_PTHREAD_LDFLAGS"
-+LDFLAGS="$LDFLAGS $EBCONF_PTHREAD_LDFLAGS"
- LIBS="$LIBS $EBCONF_EBLIBS $EBCONF_ZLIBLIBS $EBCONF_INTLLIBS"
-
-
diff --git a/app-dicts/eblook/files/eblook-1.6.1-clang-16-buildfix.patch b/app-dicts/eblook/files/eblook-1.6.1-clang-16-buildfix.patch
new file mode 100644
index 000000000000..cae0edcdb186
--- /dev/null
+++ b/app-dicts/eblook/files/eblook-1.6.1-clang-16-buildfix.patch
@@ -0,0 +1,11 @@
+Bug: https://bugs.gentoo.org/894360
+--- a/getopt.c
++++ b/getopt.c
+@@ -40,6 +40,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C