summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/cppman')
-rw-r--r--app-doc/cppman/Manifest3
-rw-r--r--app-doc/cppman/cppman-0.5.1.ebuild34
-rw-r--r--app-doc/cppman/cppman-0.5.4-r1.ebuild46
-rw-r--r--app-doc/cppman/cppman-0.5.6.ebuild52
-rw-r--r--app-doc/cppman/metadata.xml9
5 files changed, 108 insertions, 36 deletions
diff --git a/app-doc/cppman/Manifest b/app-doc/cppman/Manifest
index eba741b397ff..8c8a1421b755 100644
--- a/app-doc/cppman/Manifest
+++ b/app-doc/cppman/Manifest
@@ -1 +1,2 @@
-DIST cppman-0.5.1.tar.gz 3596049 BLAKE2B 0189da1413720c00c89a0685b83231aaf0c54e19c84ede164e892e7f8855b7b1ceb1baee11866fd99d150e9c031ccea88bcecdda816fb8e53d58b918a000e04a SHA512 3248d9795d3a379f13e43d5e0753f62a0412dcf3760b8dec6a176f08cb71c4983065c7d27eb15ffed4cc77264e66a3f7d9fe5757a8c7a582741751bcfd1b2fd6
+DIST cppman-0.5.4.tar.gz 3560915 BLAKE2B 37dae8d4f4884582fd4556bfb8778b62e332286b9438a4507dd1a401f40014964a2409a57f1b8d234bb6143555719a6b81ccdf939fcf95a46ddb0fdfd475ac32 SHA512 e401813772c393aaf0e403ee253510ad4aac9cd9733c015e195bb66dad70cb2db0ea3e3c9749d87aed04b49aee04639fa3f822dc8e69a5a8812c3992b3e5c86d
+DIST cppman-0.5.6.tar.gz 3820427 BLAKE2B ca4c3bc05e3f8b7de432147dcff861ab4b1d3b3de2729da2dc4cb8513f96b3b92e9a7ebbbf0ad577d7372ebc7d152290431d4d95127c63a1a9122c2dd5f12aae SHA512 bf4c0aa01d0a7158818f5769c66c420fb982fb3c0daaf83e4089f122e59ac5d9d2637b9ff079ea3ee7259bbb92b72992bcb2b1a593fc1bb7223288077fb523b6
diff --git a/app-doc/cppman/cppman-0.5.1.ebuild b/app-doc/cppman/cppman-0.5.1.ebuild
deleted file mode 100644
index 60a7000a55cc..000000000000
--- a/app-doc/cppman/cppman-0.5.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
-PYTHON_REQ_USE="sqlite,threads(+)"
-
-DISTUTILS_SINGLE_IMPL=true
-DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1
-
-DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
-HOMEPAGE="https://github.com/aitjcize/cppman"
-SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
-
-RDEPEND="
- sys-apps/groff
- $(python_gen_cond_dep '
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- ')
-"
-
-src_prepare() {
- default
-
- # Don't allow setup.py to install documentation directly
- sed -i '\:share/doc/cppman:d' setup.py || die "sed failed"
-}
diff --git a/app-doc/cppman/cppman-0.5.4-r1.ebuild b/app-doc/cppman/cppman-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..9e88d7bf5257
--- /dev/null
+++ b/app-doc/cppman/cppman-0.5.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 bash-completion-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ sys-apps/groff
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ # Install data manually, nearly all of it is misplaced
+ sed -i '/data_files = _data_files,/d' setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman misc/cppman.1
+
+ newbashcomp misc/completions/cppman.bash cppman
+
+ insinto /usr/share/zsh/site-functions
+ doins misc/completions/zsh/_cppman
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins misc/completions/fish/cppman.fish
+}
diff --git a/app-doc/cppman/cppman-0.5.6.ebuild b/app-doc/cppman/cppman-0.5.6.ebuild
new file mode 100644
index 000000000000..63a0409772a7
--- /dev/null
+++ b/app-doc/cppman/cppman-0.5.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 bash-completion-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ sys-apps/groff
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ # Install data manually, nearly all of it is misplaced
+ sed -i '/data_files = _data_files,/d' setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ ${EPYTHON} test/test.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman misc/cppman.1
+
+ newbashcomp misc/completions/cppman.bash cppman
+
+ insinto /usr/share/zsh/site-functions
+ doins misc/completions/zsh/_cppman
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins misc/completions/fish/cppman.fish
+}
diff --git a/app-doc/cppman/metadata.xml b/app-doc/cppman/metadata.xml
index fdf84de8835f..a2eb1022cb35 100644
--- a/app-doc/cppman/metadata.xml
+++ b/app-doc/cppman/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>esteve.varela@gmail.com</email>
+ <name>Esteve Varela Colominas</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">aitjcize/cppman</remote-id>
</upstream>