summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch
new file mode 100644
index 000000000000..54c0a96e5e1a
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch
@@ -0,0 +1,32 @@
+--- a/addon/doxysearch/CMakeLists.txt 2019-04-03 18:43:47.995610511 +0200
++++ b/addon/doxysearch/CMakeLists.txt 2019-04-03 18:45:27.730609191 +0200
+@@ -18,6 +18,7 @@
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
+ qtools
++ pthread
+ )
+
+ add_executable(doxysearch.cgi
+@@ -27,6 +28,7 @@
+ ${XAPIAN_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
++ pthread
+ )
+
+ install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
+--- a/addon/doxywizard/CMakeLists.txt 2019-04-03 18:43:59.139610364 +0200
++++ b/addon/doxywizard/CMakeLists.txt 2019-04-03 18:45:14.151609371 +0200
+@@ -102,9 +102,9 @@
+ )
+
+ if(Qt5Core_FOUND)
+- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml)
++ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml pthread)
+ else()
+- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY})
++ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} pthread)
+ endif()
+
+ install(TARGETS doxywizard DESTINATION bin)