summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild')
-rw-r--r--app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild b/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild
new file mode 100644
index 000000000000..4ba0ace025b7
--- /dev/null
+++ b/app-editors/curses-hexedit/curses-hexedit-0.9.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# There's already a "hexedit" package in the tree, so name this one differently
+
+EAPI="4"
+
+MY_P=${P/curses-}
+DESCRIPTION="full screen curses hex editor (with insert/delete support)"
+HOMEPAGE="http://www.rogoyski.com/adam/programs/hexedit/"
+SRC_URI="http://www.rogoyski.com/adam/programs/hexedit/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf --program-prefix=curses-
+}