summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/diakonos')
-rw-r--r--app-editors/diakonos/Manifest2
-rw-r--r--app-editors/diakonos/diakonos-0.9.7.ebuild (renamed from app-editors/diakonos/diakonos-0.9.4-r1.ebuild)20
-rw-r--r--app-editors/diakonos/metadata.xml5
3 files changed, 15 insertions, 12 deletions
diff --git a/app-editors/diakonos/Manifest b/app-editors/diakonos/Manifest
index 045292cca7c5..6fd115fffe4d 100644
--- a/app-editors/diakonos/Manifest
+++ b/app-editors/diakonos/Manifest
@@ -1 +1 @@
-DIST diakonos-0.9.4.tar.bz2 102282 BLAKE2B f8625d87924815e816c2f5a07e5c1d35df4df6126531caf5c98a9fdcb20eb9543c028363344a3c20f2f8a0335fa9d071b168640d9bd4738b1d51737bcc548c12 SHA512 8aab6173c40b9a182853977ed7631c391a10d3339918fa96866da8c9fa8e36e40f1c5093465c734a9ce36a69c5d994d6b2d1c0306f1e57bff708fd7a64a62db7
+DIST diakonos-0.9.7.tar.gz 129807 BLAKE2B 26c3a72a00e1d41b4a7b2916b37024658d7607ac657d4f71a12b939830578d7939a4f9f4c3886693eae9eeaf91bfe1abe055be7bcc7681619448e298acb5c546 SHA512 ec23d93ed6871d18b6a91e02bc6916ac667ca773be5f093a68fffa5c9cbe89b123e80b18762c8649620eda23b1b9ba582a5236eb9eaefc0e22a411390cd30c73
diff --git a/app-editors/diakonos/diakonos-0.9.4-r1.ebuild b/app-editors/diakonos/diakonos-0.9.7.ebuild
index 74fbd1888407..ffde7aefebca 100644
--- a/app-editors/diakonos/diakonos-0.9.4-r1.ebuild
+++ b/app-editors/diakonos/diakonos-0.9.7.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby26 ruby27 ruby30"
+USE_RUBY="ruby27 ruby30 ruby31"
inherit ruby-ng
DESCRIPTION="A Linux editor for the masses"
-HOMEPAGE="http://diakonos.pist0s.ca"
-SRC_URI="http://diakonos.pist0s.ca/archives/${P}.tar.bz2"
+HOMEPAGE="https://git.sr.ht/~pistos/diakonos"
+SRC_URI="https://github.com/Pistos/diakonos/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -19,10 +19,14 @@ IUSE="doc test"
ruby_add_rdepend "dev-ruby/curses"
ruby_add_bdepend "doc? ( dev-ruby/yard )
- test? ( dev-ruby/bacon )"
+ test? ( dev-ruby/rspec )"
+
+each_ruby_test() {
+ ${RUBY} -S rspec -Ilib spec/*.rb spec/*/*.rb || die
+}
each_ruby_install() {
- ${RUBY} install.rb --dest-dir "${D}" --doc-dir /usr/share/doc/${P} || die "install failed"
+ ${RUBY} install.rb --dest-dir "${D}" --doc-dir /usr/share/doc/${PF} || die "install failed"
}
all_ruby_install() {
@@ -31,7 +35,3 @@ all_ruby_install() {
dodoc -r doc/*
fi
}
-
-each_ruby_test() {
- ${RUBY} -S bacon -Ilib spec/*.rb spec/*/*.rb || die
-}
diff --git a/app-editors/diakonos/metadata.xml b/app-editors/diakonos/metadata.xml
index 85e4ed814fa2..412aa2db5d01 100644
--- a/app-editors/diakonos/metadata.xml
+++ b/app-editors/diakonos/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourcehut">~pistos/diakonos</remote-id>
+ </upstream>
</pkgmetadata>