summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emact/emact-2.58.0.ebuild')
-rw-r--r--app-editors/emact/emact-2.58.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-editors/emact/emact-2.58.0.ebuild b/app-editors/emact/emact-2.58.0.ebuild
new file mode 100644
index 000000000000..b5eeeec97fa3
--- /dev/null
+++ b/app-editors/emact/emact-2.58.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EmACT, a fork of Conroy's MicroEmacs"
+HOMEPAGE="http://www.eligis.com/emacs/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses:0=
+ X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with X x)
+}
+
+src_install() {
+ emake INSTALL="${D}"/usr install
+ #dodoc README
+}