summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/featherpad')
-rw-r--r--app-editors/featherpad/Manifest1
-rw-r--r--app-editors/featherpad/featherpad-0.18.0.ebuild28
-rw-r--r--app-editors/featherpad/metadata.xml20
3 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
new file mode 100644
index 000000000000..78475bb25f5f
--- /dev/null
+++ b/app-editors/featherpad/Manifest
@@ -0,0 +1 @@
+DIST featherpad-0.18.0.tar.gz 967643 BLAKE2B a8a84fa71232bdd9448ec4a9c921f8f452212dfb52ec518c3f340e9b600858a9cfca2d7729a0f58c9d1465b77bd28c836de78026c58ff94297de704e7bf670d8 SHA512 3e0d008792dd55bc5e57654f9b032f0a66a60c682499c684cfc3b182fdc57a654bb5fb195b458af66ddd8db929b31e7bfa789bd9bdf33d32454fbbcb090bcd91
diff --git a/app-editors/featherpad/featherpad-0.18.0.ebuild b/app-editors/featherpad/featherpad-0.18.0.ebuild
new file mode 100644
index 000000000000..6c98ead81b19
--- /dev/null
+++ b/app-editors/featherpad/featherpad-0.18.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-text/hunspell
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+S="${WORKDIR}/FeatherPad-${PV}"
diff --git a/app-editors/featherpad/metadata.xml b/app-editors/featherpad/metadata.xml
new file mode 100644
index 000000000000..3fd6253bfc08
--- /dev/null
+++ b/app-editors/featherpad/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>hansfn@gmail.com</email>
+ <name>Hans Fredrik Nordhaug</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ FeatherPad (by Pedram Pourang, a.k.a. Tsu Jan) is a lightweight Qt
+ plain-text editor for Linux. It is independent of any desktop
+ environment.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">tsujan/FeatherPad</remote-id>
+ </upstream>
+</pkgmetadata>