summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/focuswriter')
-rw-r--r--app-editors/focuswriter/Manifest2
-rw-r--r--app-editors/focuswriter/files/focuswriter-1.5.2-unbundle-qtsingleapplication.patch36
-rw-r--r--app-editors/focuswriter/focuswriter-1.5.3.ebuild67
-rw-r--r--app-editors/focuswriter/focuswriter-1.5.4.ebuild67
-rw-r--r--app-editors/focuswriter/metadata.xml5
5 files changed, 177 insertions, 0 deletions
diff --git a/app-editors/focuswriter/Manifest b/app-editors/focuswriter/Manifest
new file mode 100644
index 000000000000..c2bf16344ccc
--- /dev/null
+++ b/app-editors/focuswriter/Manifest
@@ -0,0 +1,2 @@
+DIST focuswriter-1.5.3-src.tar.bz2 5201148 SHA256 1c48c72879a7b40cf7d97c28abf5cf713c063b7f83a1179093b1241f5797a8c4 SHA512 6796fc8dbe5d5ba545fc8ee5797f620e56dea67a038f4c4eb9e404940a863b32ea2ceb30ed7ea8e22187be2763cc128def3f08f61187ba11de94ec9ae16f807f WHIRLPOOL c5dbf0e739928833bbccdc2e5de6305ca553a3e8f0f1d54d1d2a6bd4636b8ede85c3adedcaee85d66779e25cd53678428cc3817bdedcf30be42c89fc1aebdf07
+DIST focuswriter-1.5.4-src.tar.bz2 5247111 SHA256 5ffd74a2d5a790e432d819dfd269ddb8d6c1a0168c91e441b2121fa6eaf8f565 SHA512 f532dac5a0691d7b82a16b5dae115c7d79b161484ba1ad2243fd1ccaeba8ae9c9ed0019eba6cd87cc4155a51f5a97cad16c92b9453671426e214e139d78bc526 WHIRLPOOL aca3722b60aee8bec0979f71a04d28217c82c9a2fb60b49a19a58596c9d67bd160626d14cc950eeaa9c0543001f93ec9576a1561c24bbe29a98eeec708287331
diff --git a/app-editors/focuswriter/files/focuswriter-1.5.2-unbundle-qtsingleapplication.patch b/app-editors/focuswriter/files/focuswriter-1.5.2-unbundle-qtsingleapplication.patch
new file mode 100644
index 000000000000..e7815be0ee5f
--- /dev/null
+++ b/app-editors/focuswriter/files/focuswriter-1.5.2-unbundle-qtsingleapplication.patch
@@ -0,0 +1,36 @@
+--- focuswriter.pro.orig 2014-07-20 17:37:05.000000000 +0400
++++ focuswriter.pro 2014-07-31 17:56:00.702801120 +0400
+@@ -90,13 +90,14 @@
+ src/spelling/dictionary_provider_voikko.cpp
+
+ lessThan(QT_MAJOR_VERSION, 5) {
++ CONFIG += qtsingleapplication
+ SOURCES += src/sdl/sound.cpp
+ } else {
+ SOURCES += src/sound.cpp
+ }
+ }
+
+-INCLUDEPATH += src src/fileformats src/qtsingleapplication src/qtzip src/spelling
++INCLUDEPATH += src src/fileformats src/qtzip src/spelling
+
+ # Specify program sources
+ HEADERS += src/action_manager.h \
+@@ -155,8 +156,6 @@
+ src/fileformats/rtf_tokenizer.h \
+ src/fileformats/rtf_writer.h \
+ src/fileformats/txt_reader.h \
+- src/qtsingleapplication/qtsingleapplication.h \
+- src/qtsingleapplication/qtlocalpeer.h \
+ src/qtzip/qtzipreader.h \
+ src/qtzip/qtzipwriter.h \
+ src/spelling/abstract_dictionary.h \
+@@ -219,8 +218,6 @@
+ src/fileformats/rtf_tokenizer.cpp \
+ src/fileformats/rtf_writer.cpp \
+ src/fileformats/txt_reader.cpp \
+- src/qtsingleapplication/qtsingleapplication.cpp \
+- src/qtsingleapplication/qtlocalpeer.cpp \
+ src/qtzip/qtzip.cpp \
+ src/spelling/dictionary_dialog.cpp \
+ src/spelling/dictionary_manager.cpp \
diff --git a/app-editors/focuswriter/focuswriter-1.5.3.ebuild b/app-editors/focuswriter/focuswriter-1.5.3.ebuild
new file mode 100644
index 000000000000..fc6e598f6aa1
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.5.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ar ca cs da de el en en_GB es_MX es fi fr he hu hy id it ja ko nl pl
+pt_BR pt ro ru sk sr sv tr uk vi zh_CN zh_TW"
+PLOCALE_BACKUP="en"
+inherit fdo-mime gnome2-utils l10n readme.gentoo qt4-r2
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="http://gottcode.org/focuswriter/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="app-text/hunspell
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsingleapplication[qt4(+),X]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog CREDITS NEWS README )
+DOC_CONTENTS="Focuswriter has optional sound support if media-libs/sdl-mixer is
+installed with wav useflag enabled."
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.2-unbundle-qtsingleapplication.patch" )
+
+rm_loc() {
+ sed -e "s|translations/${PN}_${1}.ts||" -i ${PN}.pro || die 'sed failed'
+ rm translations/${PN}_${1}.{ts,qm} || die "removing ${1} locale failed"
+}
+
+src_prepare() {
+ l10n_for_each_disabled_locale_do rm_loc
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ qt4-r2_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
diff --git a/app-editors/focuswriter/focuswriter-1.5.4.ebuild b/app-editors/focuswriter/focuswriter-1.5.4.ebuild
new file mode 100644
index 000000000000..f2e23064f6b9
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.5.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ar ca cs da de el en en_GB es_MX es fi fr he hu hy id it ja ko nl pl
+pt_BR pt ro ru sk sr sv tr uk vi zh_CN zh_TW"
+PLOCALE_BACKUP="en"
+inherit fdo-mime gnome2-utils l10n readme.gentoo qt4-r2
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="http://gottcode.org/focuswriter/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="app-text/hunspell
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsingleapplication[qt4(+),X]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog CREDITS NEWS README )
+DOC_CONTENTS="Focuswriter has optional sound support if media-libs/sdl-mixer is
+installed with wav useflag enabled."
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.2-unbundle-qtsingleapplication.patch" )
+
+rm_loc() {
+ sed -e "s|translations/${PN}_${1}.ts||" -i ${PN}.pro || die 'sed failed'
+ rm translations/${PN}_${1}.{ts,qm} || die "removing ${1} locale failed"
+}
+
+src_prepare() {
+ l10n_for_each_disabled_locale_do rm_loc
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ qt4-r2_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
diff --git a/app-editors/focuswriter/metadata.xml b/app-editors/focuswriter/metadata.xml
new file mode 100644
index 000000000000..ab02f994fdd2
--- /dev/null
+++ b/app-editors/focuswriter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+</pkgmetadata>