summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kile')
-rw-r--r--app-editors/kile/Manifest3
-rw-r--r--app-editors/kile/files/kile-2.9.93-cmake.patch20
-rw-r--r--app-editors/kile/files/kile-2.9.93-fix-crash-when-deleting-templates.patch35
-rw-r--r--app-editors/kile/files/kile-2.9.93-fix-ktoolbar-usage.patch25
-rw-r--r--app-editors/kile/files/kile-2.9.93-fix-overriding-existing-templates.patch164
-rw-r--r--app-editors/kile/files/kile-2.9.93-no-khtml.patch58
-rw-r--r--app-editors/kile/files/kile-2.9.93_p20221123-cmake.patch31
-rw-r--r--app-editors/kile/files/kile-2.9.93_p20221123-okularpart.patch70
-rw-r--r--app-editors/kile/kile-2.9.93_p20221123-r1.ebuild (renamed from app-editors/kile/kile-2.9.93-r1.ebuild)45
-rw-r--r--app-editors/kile/kile-2.9.94.ebuild73
-rw-r--r--app-editors/kile/metadata.xml3
11 files changed, 202 insertions, 325 deletions
diff --git a/app-editors/kile/Manifest b/app-editors/kile/Manifest
index 83e824de2f59..6b54e8a4c12d 100644
--- a/app-editors/kile/Manifest
+++ b/app-editors/kile/Manifest
@@ -1 +1,2 @@
-DIST kile-2.9.93.tar.bz2 8580239 BLAKE2B a43f160240dfdffc23c6898385994ee4e49e1f3d793915d1f392e41f606350269f2b9e80592c373680adb56454510abdd0b7e69131f20737fb5efa54d4eaa111 SHA512 d87277b8ef16c82cfd415dd191916641fa1a25e316e1eb2c463b275d3654dcfe180bea03027589ab30cd8b769d92d97005846a78aff8058bcfb20eed76287504
+DIST kile-2.9.93_p20221123-1ca67389.tar.gz 9507069 BLAKE2B 61770aeafe6604b8a45ae9e49fc79a375815fce5e11a189aef962172f60d0182984f6908a626cb95b493f1fe894958ec0816420096a12efbd03233114e0a5dcc SHA512 ed16cfb7cee3d08ad21fabecd5536981c68431261c02f66cc979f5f01229fa33c192c33f5d1ef78d61c37e643ab313eb432fd580aea61f5a918d3de76d2dcadc
+DIST kile-2.9.94.tar.bz2 7505095 BLAKE2B b42d7237f612f2d6017bdde3cfea29a74b4756b96cc707b178217e0ab5b599d86b2ffc8e0283fcd6e351746151738bcbff65183b93a347c6fb11250233b7fe5a SHA512 4638e81374243a8b2716183bf28cec02bcb455f2b1a9295e7e04f20833b77c962bddfeb81e527606209c338862af48a38d9f6009a9f7b96aac37f874ae3f725c
diff --git a/app-editors/kile/files/kile-2.9.93-cmake.patch b/app-editors/kile/files/kile-2.9.93-cmake.patch
deleted file mode 100644
index 94e39c463517..000000000000
--- a/app-editors/kile/files/kile-2.9.93-cmake.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-I know upstream wants to help us but it doesn't work...
-
---- a/CMakeLists.txt 2019-10-19 14:23:41.000000000 +0200
-+++ b/CMakeLists.txt 2019-10-20 15:50:52.606325681 +0200
-@@ -116,15 +116,6 @@
- kile2.0-5_upd.pl
- DESTINATION ${KDE_INSTALL_DATAROOTDIR}/kconf_update)
-
--install(FILES
-- AUTHORS
-- ChangeLog
-- README
-- README.cwl
-- kile-remote-control.txt
-- README.MacOSX
-- DESTINATION ${KDE_INSTALL_DATAROOTDIR}/doc/kile)
--
- feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
- find_package(KF5I18n CONFIG REQUIRED)
- ki18n_install(po)
diff --git a/app-editors/kile/files/kile-2.9.93-fix-crash-when-deleting-templates.patch b/app-editors/kile/files/kile-2.9.93-fix-crash-when-deleting-templates.patch
deleted file mode 100644
index 232bd3894833..000000000000
--- a/app-editors/kile/files/kile-2.9.93-fix-crash-when-deleting-templates.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 483743aa9f194376a8b496ac4e58a946070a36af Mon Sep 17 00:00:00 2001
-From: Michel Ludwig <michel.ludwig@kdemail.net>
-Date: Sun, 1 Dec 2019 09:09:55 +0100
-Subject: [PATCH] Don't crash when deleting templates
-
-BUG: 413506
----
- src/dialogs/managetemplatesdialog.cpp | 11 -----------
- 1 file changed, 11 deletions(-)
-
-diff --git a/src/dialogs/managetemplatesdialog.cpp b/src/dialogs/managetemplatesdialog.cpp
-index fe6537ad..c5298b21 100644
---- a/src/dialogs/managetemplatesdialog.cpp
-+++ b/src/dialogs/managetemplatesdialog.cpp
-@@ -317,17 +317,6 @@ bool ManageTemplatesDialog::removeTemplate()
-
- KileTemplate::Info templateInfo = templateItem->getTemplateInfo();
-
-- KIO::StatJob* statJob = KIO::stat(QUrl::fromUserInput(templateInfo.path), KIO::StatJob::DestinationSide, 0);
-- KIO::StatJob* statJob2 = KIO::stat(QUrl::fromUserInput(templateInfo.icon), KIO::StatJob::DestinationSide, 0);
-- KJobWidgets::setWindow(statJob, this);
-- KJobWidgets::setWindow(statJob2, this);
-- statJob->exec();
-- statJob2->exec();
-- if ((statJob->error() && statJob2->error()) || !QFileInfo(templateInfo.icon).exists()) {
-- KMessageBox::error(this, i18n("Sorry, but you do not have the necessary permissions to remove the selected template."));
-- return false;
-- }
--
- if (KMessageBox::warningYesNo(this, i18n("You are about to remove the template \"%1\"; are you sure?", templateInfo.name)) == KMessageBox::No) {
- return false;
- }
---
-GitLab
-
diff --git a/app-editors/kile/files/kile-2.9.93-fix-ktoolbar-usage.patch b/app-editors/kile/files/kile-2.9.93-fix-ktoolbar-usage.patch
deleted file mode 100644
index 2afd0622ea3d..000000000000
--- a/app-editors/kile/files/kile-2.9.93-fix-ktoolbar-usage.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 5c268679da2fb2cdc414890bdd79a5592e37cb22 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andrius=20=C5=A0tikonas?= <andrius@stikonas.eu>
-Date: Tue, 15 Sep 2020 15:33:51 +0100
-Subject: [PATCH] Fix KToolbar usage.
-
----
- src/widgets/scriptsmanagementwidget.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/widgets/scriptsmanagementwidget.cpp b/src/widgets/scriptsmanagementwidget.cpp
-index 79552da3..94f58f18 100644
---- a/src/widgets/scriptsmanagementwidget.cpp
-+++ b/src/widgets/scriptsmanagementwidget.cpp
-@@ -66,7 +66,7 @@ ScriptsManagement::ScriptsManagement(KileInfo *kileInfo, QWidget *parent, const
- baseLayout->setContentsMargins(0, 0, 0, 0);
- setLayout(baseLayout);
-
-- m_toolBar = new KToolBar(this, "scriptControlToolBar");
-+ m_toolBar = new KToolBar("scriptControlToolBar", this);
- m_toolBar->setToolButtonStyle(Qt::ToolButtonIconOnly);
- m_toolBar->setIconDimensions(KIconLoader::SizeSmall);
-
---
-GitLab
-
diff --git a/app-editors/kile/files/kile-2.9.93-fix-overriding-existing-templates.patch b/app-editors/kile/files/kile-2.9.93-fix-overriding-existing-templates.patch
deleted file mode 100644
index f303cff0b0f0..000000000000
--- a/app-editors/kile/files/kile-2.9.93-fix-overriding-existing-templates.patch
+++ /dev/null
@@ -1,164 +0,0 @@
-From 7a55cf2d93c9daa13f2fa2ec1ae25646507cfc0c Mon Sep 17 00:00:00 2001
-From: Michel Ludwig <michel.ludwig@kdemail.net>
-Date: Sun, 1 Dec 2019 15:56:05 +0100
-Subject: [PATCH] Fix overriding of existing templates
-
-Also, don't delete the original file after the template has been
-created from it.
-
-BUG: 413473
-
-* asturm 2020-10-17: backport to 2.9.93 (drop unnecessary string change)
-
----
- src/dialogs/managetemplatesdialog.cpp | 7 ++-
- src/templates.cpp | 78 ++-------------------------
- src/templates.h | 10 ++--
- 3 files changed, 12 insertions(+), 83 deletions(-)
-
-diff --git a/src/dialogs/managetemplatesdialog.cpp b/src/dialogs/managetemplatesdialog.cpp
-index c5298b21..77d5d6ff 100644
---- a/src/dialogs/managetemplatesdialog.cpp
-+++ b/src/dialogs/managetemplatesdialog.cpp
-@@ -292,11 +292,10 @@ void ManageTemplatesDialog::addTemplate()
- reject();
- return;
- }
-- returnValue = m_templateManager->replace(templateInfo, m_sourceURL, templateName, iconURL);
-- }
-- else {
-- returnValue = m_templateManager->add(m_sourceURL, templateName, iconURL);
- }
-+
-+ returnValue = m_templateManager->add(m_sourceURL, templateName, iconURL);
-+
- if (!returnValue) {
- KMessageBox::error(this, i18n("Failed to create the template."));
- reject();
-diff --git a/src/templates.cpp b/src/templates.cpp
---- a/src/templates.cpp
-+++ b/src/templates.cpp
-@@ -82,7 +82,10 @@ bool Manager::copyAppData(const QUrl &src, const QString& subdir, const QString&
- testDir.mkpath(dir);
- }
- // copy file
-- KIO::FileCopyJob* copyJob = KIO::file_copy(src, targetURL);
-+ if(src == targetURL) { // copying a file over itself
-+ return true;
-+ }
-+ KIO::FileCopyJob* copyJob = KIO::file_copy(src, targetURL, -1, KIO::Overwrite);
- KJobWidgets::setWindow(copyJob, m_kileInfo->mainWindow());
- return copyJob->exec();
- }
-@@ -130,77 +133,6 @@ bool Manager::remove(Info ti) {
- return removeAppData(ti.path) && removeAppData(ti.icon);
- }
-
--bool Manager::replace(const KileTemplate::Info& toBeReplaced, const QUrl &newTemplateSourceURL, const QString& newName, const QUrl& newIcon) {
-- KileDocument::Type type = m_kileInfo->extensions()->determineDocumentType(newTemplateSourceURL);
--
-- //start by copying the files that belong to the new template to a safe place
-- QString templateTempFile, iconTempFile;
--
-- if( newTemplateSourceURL.isLocalFile() ) {
-- // file protocol. We do not need the network
-- templateTempFile = newTemplateSourceURL.toLocalFile();
-- }
-- else {
-- QTemporaryFile tmpFile;
-- tmpFile.setAutoRemove( false );
-- tmpFile.open();
--
-- templateTempFile = tmpFile.fileName();
-- m_TempFilePath = tmpFile.fileName();
-- KIO::FileCopyJob* fileCopyJob = KIO::file_copy( newTemplateSourceURL, QUrl::fromLocalFile(templateTempFile), -1, KIO::Overwrite );
-- KJobWidgets::setWindow( fileCopyJob, m_kileInfo->mainWindow() );
--
-- if( ! fileCopyJob->exec() ) {
-- return false;
-- }
-- }
--
-- if( newIcon.isLocalFile() ) {
-- // file protocol. We do not need the network
-- iconTempFile = newIcon.toLocalFile();
-- }
-- else {
-- QTemporaryFile tmpFile;
-- tmpFile.setAutoRemove( false );
-- tmpFile.open();
--
-- iconTempFile = tmpFile.fileName();
-- m_TempFilePath = tmpFile.fileName();
-- KIO::FileCopyJob* fileCopyJob = KIO::file_copy( newIcon, QUrl::fromLocalFile(iconTempFile), -1, KIO::Overwrite );
-- KJobWidgets::setWindow( fileCopyJob, m_kileInfo->mainWindow() );
--
-- if( ! fileCopyJob->exec() ) {
-- if( ! templateTempFile.isEmpty() )
-- QFile::remove( templateTempFile );
-- return false;
-- }
-- }
--
-- //now delete the template that should be replaced
-- if(!remove(toBeReplaced)) {
-- if( ! templateTempFile.isEmpty() )
-- QFile::remove( templateTempFile );
-- if( ! iconTempFile.isEmpty() )
-- QFile::remove( iconTempFile );
-- }
--
-- //finally, create the new template
-- if(!add(QUrl::fromUserInput(templateTempFile), type, newName, QUrl::fromUserInput(iconTempFile))) {
-- if( ! templateTempFile.isEmpty() )
-- QFile::remove( templateTempFile );
-- if( ! iconTempFile.isEmpty() )
-- QFile::remove( iconTempFile );
-- return false;
-- }
--
-- if( ! templateTempFile.isEmpty() )
-- QFile::remove( templateTempFile );
-- if( ! iconTempFile.isEmpty() )
-- QFile::remove( iconTempFile );
--
-- return true;
--}
--
- void Manager::scanForTemplates() {
- KILE_DEBUG_MAIN << "===scanForTemplates()===================";
- QStringList dirs = KileUtilities::locateAll(QStandardPaths::AppDataLocation, "templates", QStandardPaths::LocateDirectory);
-diff --git a/src/templates.h b/src/templates.h
---- a/src/templates.h
-+++ b/src/templates.h
-@@ -1,7 +1,7 @@
- /***************************************************************************************
- begin : Sat Apr 26 2003
- copyright : (C) 2003 by Jeroen Wijnhout (wijnhout@science.uva.nl)
-- 2007, 2008 by Michel Ludwig (michel.ludwig@kdemail.net)
-+ 2007-2019 by Michel Ludwig (michel.ludwig@kdemail.net)
- ***************************************************************************************/
-
- /***************************************************************************
-@@ -79,15 +79,13 @@ public:
- **/
- bool searchForTemplate(const QString& name, KileDocument::Type& type) const;
-
-- // add a template in $HOME/kile/templates/
-+ // Add a template in .kde/share/kile/templates/
-+ // This function will override any existing template.
- bool add(const QUrl &templateSourceURL, const QString &name, const QUrl &icon);
-
-- // remove a template from $HOME/kile/templates/
-+ // Remove a template from .kde/share/kile/templates/
- bool remove(KileTemplate::Info ti);
-
-- // replaces a template
-- bool replace(const KileTemplate::Info& toBeReplaced, const QUrl &newTemplateSourceURL, const QString& newName, const QUrl& newIcon);
--
- // these have to be methods as we cannot use i18n calls in global objects
- static QString defaultEmptyTemplateCaption();
- static QString defaultEmptyLaTeXTemplateCaption();
---
-GitLab
-
diff --git a/app-editors/kile/files/kile-2.9.93-no-khtml.patch b/app-editors/kile/files/kile-2.9.93-no-khtml.patch
deleted file mode 100644
index cf055fc84490..000000000000
--- a/app-editors/kile/files/kile-2.9.93-no-khtml.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 7c050b5e306cab115573aea1bfc951aaaa1203e9 Mon Sep 17 00:00:00 2001
-From: Michel Ludwig <michel.ludwig@kdemail.net>
-Date: Fri, 22 Nov 2019 09:40:53 +0100
-Subject: [PATCH] Remove dependency on KHTML
-
----
- CMakeLists.txt | 1 -
- src/CMakeLists.txt | 2 --
- src/kilelauncher.cpp | 1 -
- 3 files changed, 4 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1bea621f..1b25e3a4 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -46,7 +46,6 @@ find_package(KF5 5.31 REQUIRED COMPONENTS
- I18n
- IconThemes
- Init
-- KHtml
- KIO
- Parts
- TextEditor
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 77626894..e23480fd 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -55,7 +55,6 @@ set(kile_SRCS
- dialogs/usermenu/usermenuitem.cpp
- dialogs/usermenu/usermenutree.cpp
- dialogs/validatorinputdialog.cpp
-- docpart.cpp
- documentinfo.cpp
- editorcommands.cpp
- editorextension.cpp
-@@ -238,7 +237,6 @@ PUBLIC
- KF5::Crash
- KF5::DBusAddons
- KF5::GuiAddons
-- KF5::KHtml
- KF5::I18n
- KF5::IconThemes
- KF5::KIOCore
-diff --git a/src/kilelauncher.cpp b/src/kilelauncher.cpp
-index c0bcdf9d..24a1f5b4 100644
---- a/src/kilelauncher.cpp
-+++ b/src/kilelauncher.cpp
-@@ -16,7 +16,6 @@
-
- #include <config.h>
-
--#include "docpart.h"
- #include "kileconfig.h"
- #include "kileinfo.h"
- #include "kiletool.h"
---
-GitLab
-
diff --git a/app-editors/kile/files/kile-2.9.93_p20221123-cmake.patch b/app-editors/kile/files/kile-2.9.93_p20221123-cmake.patch
new file mode 100644
index 000000000000..0095adf9548c
--- /dev/null
+++ b/app-editors/kile/files/kile-2.9.93_p20221123-cmake.patch
@@ -0,0 +1,31 @@
+From 2974fba837aef46711d9e1b26cd367aab68ba53a Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Wed, 19 Dec 2018 13:36:12 +0100
+Subject: [PATCH] Disable install misc files by cmake
+
+AUTHORS, README, Changelog etc. are handled by distribution packages.
+---
+ CMakeLists.txt | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 91a732ab..c69c168c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -114,13 +114,6 @@ install(
+ kile2.0-5_upd.pl
+ DESTINATION ${KDE_INSTALL_DATAROOTDIR}/kconf_update)
+
+-install(FILES
+- AUTHORS
+- ChangeLog
+- README
+- README.cwl
+- kile-remote-control.txt
+- DESTINATION ${KDE_INSTALL_DATAROOTDIR}/doc/kile)
+
+ ki18n_install(po)
+
+--
+2.38.1
+
diff --git a/app-editors/kile/files/kile-2.9.93_p20221123-okularpart.patch b/app-editors/kile/files/kile-2.9.93_p20221123-okularpart.patch
new file mode 100644
index 000000000000..7a66dfcc4f80
--- /dev/null
+++ b/app-editors/kile/files/kile-2.9.93_p20221123-okularpart.patch
@@ -0,0 +1,70 @@
+From 6cf4549217e95659c8dfd14f9166fb8b80bad333 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Fri, 15 Mar 2024 12:45:51 +0100
+Subject: [PATCH] Switch okular headers to okular5
+
+Otherwise it will be using okular6's.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/configtester.cpp | 2 +-
+ src/kileviewmanager.cpp | 2 +-
+ src/kileviewmanager.h | 2 +-
+ src/livepreview.cpp | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/configtester.cpp b/src/configtester.cpp
+index 35ce3e71..cd7ed588 100644
+--- a/src/configtester.cpp
++++ b/src/configtester.cpp
+@@ -14,7 +14,7 @@
+
+ #include "configtester.h"
+
+-#include <okular/interfaces/viewerinterface.h>
++#include <okular5/interfaces/viewerinterface.h>
+
+ #include <QTimer>
+
+diff --git a/src/kileviewmanager.cpp b/src/kileviewmanager.cpp
+index 34f84397..f5ac0cdc 100644
+--- a/src/kileviewmanager.cpp
++++ b/src/kileviewmanager.cpp
+@@ -15,7 +15,7 @@
+ #include "kileviewmanager.h"
+ #include <config.h>
+
+-#include <okular/interfaces/viewerinterface.h>
++#include <okular5/interfaces/viewerinterface.h>
+
+ #include <KAcceleratorManager>
+ #include <KActionCollection>
+diff --git a/src/kileviewmanager.h b/src/kileviewmanager.h
+index 42367291..e0b3ca09 100644
+--- a/src/kileviewmanager.h
++++ b/src/kileviewmanager.h
+@@ -15,7 +15,7 @@
+ #ifndef KILEVIEWKILEVIEWMANAGER_H
+ #define KILEVIEWKILEVIEWMANAGER_H
+
+-#include <okular/interfaces/viewerinterface.h>
++#include <okular5/interfaces/viewerinterface.h>
+
+ #include <KTextEditor/Cursor>
+ #include <KTextEditor/ModificationInterface>
+diff --git a/src/livepreview.cpp b/src/livepreview.cpp
+index dbd7ff13..fcfa2a6d 100644
+--- a/src/livepreview.cpp
++++ b/src/livepreview.cpp
+@@ -40,7 +40,7 @@
+ #include <KParts/MainWindow>
+ #include <KXMLGUIFactory>
+
+-#include <okular/interfaces/viewerinterface.h>
++#include <okular5/interfaces/viewerinterface.h>
+
+ #include "errorhandler.h"
+ #include "kiledebug.h"
+--
+2.44.0
+
diff --git a/app-editors/kile/kile-2.9.93-r1.ebuild b/app-editors/kile/kile-2.9.93_p20221123-r1.ebuild
index bd4e9a081820..3c11cf77aae7 100644
--- a/app-editors/kile/kile-2.9.93-r1.ebuild
+++ b/app-editors/kile/kile-2.9.93_p20221123-r1.ebuild
@@ -1,24 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
ECM_HANDBOOK="forceoptional"
KDE_ORG_CATEGORY="office"
-KFMIN=5.74.0
-QTMIN=5.14.2
+KDE_ORG_COMMIT="1ca67389327d63fdc5a4c65ab6dd1cf7fbf597af"
+KFMIN=5.82.0
+QTMIN=5.15.5
inherit ecm kde.org
DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks"
HOMEPAGE="https://apps.kde.org/kile/ https://kile.sourceforge.io/"
-if [[ ${KDE_BUILD_TYPE} == release ]]; then
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- KEYWORDS="amd64 x86"
-fi
-
LICENSE="FDL-1.2 GPL-2"
SLOT="5"
+KEYWORDS="amd64 ~arm64 ~riscv x86"
IUSE="+pdf +png"
DEPEND="
@@ -26,7 +23,10 @@ DEPEND="
>=dev-qt/qtscript-${QTMIN}:5
>=dev-qt/qttest-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
- kde-apps/okular:5
+ || (
+ media-gfx/okularpart:5[pdf?]
+ kde-apps/okular:5[pdf?]
+ )
>=kde-frameworks/kconfig-${KFMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/kcrash-${KFMIN}:5
@@ -35,7 +35,6 @@ DEPEND="
>=kde-frameworks/kguiaddons-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kinit-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
>=kde-frameworks/kparts-${KFMIN}:5
>=kde-frameworks/ktexteditor-${KFMIN}:5
@@ -44,8 +43,10 @@ DEPEND="
pdf? ( app-text/poppler[qt5] )
"
RDEPEND="${DEPEND}
- kde-apps/konsole:5
- kde-apps/okular:5[pdf?]
+ || (
+ kde-apps/konsolepart:5
+ kde-apps/konsole:5
+ )
virtual/latex-base
virtual/tex-base
pdf? (
@@ -58,15 +59,17 @@ RDEPEND="${DEPEND}
)
"
-DOCS=( AUTHORS ChangeLog kile-remote-control.txt README{,.cwl} )
+DOCS=( kile-remote-control.txt )
-PATCHES=(
- "${FILESDIR}/${P}-cmake.patch"
- "${FILESDIR}/${P}-no-khtml.patch"
- "${FILESDIR}/${P}-fix-crash-when-deleting-templates.patch"
- "${FILESDIR}/${P}-fix-overriding-existing-templates.patch"
- "${FILESDIR}/${P}-fix-ktoolbar-usage.patch"
-)
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_prepare() {
+ if has_version "media-gfx/okularpart:5"; then
+ eapply "${FILESDIR}/${P}-okularpart.patch"
+ fi
+
+ ecm_src_prepare
+}
src_configure() {
local mycmakeargs=(
diff --git a/app-editors/kile/kile-2.9.94.ebuild b/app-editors/kile/kile-2.9.94.ebuild
new file mode 100644
index 000000000000..f4817b7192ce
--- /dev/null
+++ b/app-editors/kile/kile-2.9.94.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_CATEGORY="office"
+KFMIN=6.0.0
+QTMIN=6.6.2
+MY_P=${P/_beta/b}
+inherit ecm kde.org
+
+DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/kile/ https://kile.sourceforge.io/"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="FDL-1.2 GPL-2"
+SLOT="0"
+IUSE="+pdf +png"
+
+DEPEND="
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ kde-apps/okular:6
+ >=kde-frameworks/kcodecs-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kdoctools-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kparts-${KFMIN}:6
+ >=kde-frameworks/ktexteditor-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ pdf? ( >=app-text/poppler-23.12.0[qt6] )
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5
+ kde-apps/konsole:6
+ kde-apps/okular:6[pdf?]
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ app-text/ghostscript-gpl
+ app-text/texlive-core
+ )
+ png? (
+ app-text/dvipng
+ virtual/imagemagick-tools[png?]
+ )
+"
+
+DOCS=( kile-remote-control.txt )
+
+PATCHES=( "${FILESDIR}/${PN}-2.9.93_p20221123-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package pdf Poppler)
+ )
+ ecm_src_configure
+}
diff --git a/app-editors/kile/metadata.xml b/app-editors/kile/metadata.xml
index 84ab11c2e4b4..d7c15bc148fe 100644
--- a/app-editors/kile/metadata.xml
+++ b/app-editors/kile/metadata.xml
@@ -10,7 +10,8 @@
<name>Gentoo TeX Project</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">kile</remote-id>
<bugs-to>https://bugs.kde.org/</bugs-to>
+ <remote-id type="sourceforge">kile</remote-id>
+ <remote-id type="kde-invent">office/kile</remote-id>
</upstream>
</pkgmetadata>