summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ne')
-rw-r--r--app-editors/ne/Manifest3
-rw-r--r--app-editors/ne/ne-3.3.1.ebuild10
-rw-r--r--app-editors/ne/ne-3.3.2.ebuild61
-rw-r--r--app-editors/ne/ne-3.3.3.ebuild (renamed from app-editors/ne/ne-3.3.0.ebuild)26
4 files changed, 84 insertions, 16 deletions
diff --git a/app-editors/ne/Manifest b/app-editors/ne/Manifest
index f8c4a374195d..2b9232daa17f 100644
--- a/app-editors/ne/Manifest
+++ b/app-editors/ne/Manifest
@@ -1,2 +1,3 @@
-DIST ne-3.3.0.tar.gz 1173159 BLAKE2B a4be3fd37a0a79b440290846184bc50551cfb9b73dc50c0376110f3603233879b396f67a87e2f9defe9c0cbc42c963e66bc43ab5396f8ccb27e5b6182c429006 SHA512 73a1bbc5a9f62354834288e25b8f4bf2b0d2ff6faf3408108b217305e2c9d8fed768b5a3c3fd21df7b3bf75a3f9c71ea899a8b3f528b560a8e5e66accd442919
DIST ne-3.3.1.tar.gz 1138072 BLAKE2B 8494ff955b456bbac2e82823ee155980f8fab5a1071d0bfd6a987f1ed0724129ab2ecb70737547836b592369b45daf5e499d50d7230b04c5eabfd1536a56271f SHA512 d8c1d8cd9bbafcc7c8c485ca4454d6979be3d33ae918139865ce5f76e428f165043707c95c2e440bd9bccd00c67ce81a41f87f94b85cae3518c4749233718123
+DIST ne-3.3.2.tar.gz 1154326 BLAKE2B 8c11abac9a960a41de2faed9b2e948cca9ca7f8345757796fb7daa112e62d565096b1cd3a4ca2e76cfb1616ee8c0dad01bb2fe5306bac6f0aadca0644b91eb6d SHA512 6c4fabb0ecade31322d5f96203f3bba3316264d8f98a46188796ce88f4b7fd17af8569832ae2638770f8ceb59138b0395b0e03817db961bfe94c917fa390ebf3
+DIST ne-3.3.3.tar.gz 1162423 BLAKE2B 72db1088757eb752e94480e0d0f02a85edc2df8b45bb6de732c43a6b6bfbcf0d54038462f8730ef3772a81f13ce0ca6154cced5aa10f1a0aa96ddc8697a0aaff SHA512 13bf4fae6977230cd7f3b46d12a25a605d2e83e363cf54202dc4b9e8fb19cc51bac5f30611166839bc1f717c5367db272c8d215b8006f7aa9eec312a817d35c7
diff --git a/app-editors/ne/ne-3.3.1.ebuild b/app-editors/ne/ne-3.3.1.ebuild
index 6fa202479207..a0ce06a3a43c 100644
--- a/app-editors/ne/ne-3.3.1.ebuild
+++ b/app-editors/ne/ne-3.3.1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
HOMEPAGE="https://ne.di.unimi.it/"
SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
BDEPEND="virtual/pkgconfig"
DEPEND="sys-libs/ncurses:="
diff --git a/app-editors/ne/ne-3.3.2.ebuild b/app-editors/ne/ne-3.3.2.ebuild
new file mode 100644
index 000000000000..4743055eb679
--- /dev/null
+++ b/app-editors/ne/ne-3.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="https://ne.di.unimi.it/"
+SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+BDEPEND="virtual/pkgconfig"
+
+HTML_DOCS=( doc/html/. )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.1-respect-CFLAGS.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's/-O3//' \
+ -e 's/-Wp,-D_FORTIFY_SOURCE=2//' \
+ src/makefile || die
+}
+
+src_configure() {
+ # bug #776799
+ sed -i -e "s/-lcurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" src/makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c11
+
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/${PN}" \
+ OPTS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ "${PN}"
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /usr/share/${PN}/syntax
+ doins syntax/*.jsf
+
+ doman doc/${PN}.1
+ dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
+}
diff --git a/app-editors/ne/ne-3.3.0.ebuild b/app-editors/ne/ne-3.3.3.ebuild
index 87aaff065bf8..0c90f784c008 100644
--- a/app-editors/ne/ne-3.3.0.ebuild
+++ b/app-editors/ne/ne-3.3.3.ebuild
@@ -1,31 +1,35 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
HOMEPAGE="https://ne.di.unimi.it/"
SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-BDEPEND="virtual/pkgconfig"
DEPEND="sys-libs/ncurses:="
RDEPEND="
${DEPEND}
dev-lang/perl
"
+BDEPEND="virtual/pkgconfig"
HTML_DOCS=( doc/html/. )
src_prepare() {
default
- sed -i -e 's/-O3//' src/makefile || die
+ sed -i \
+ -e 's/-O3//' \
+ -e 's/-Wp,-D_FORTIFY_SOURCE=2//' \
+ -e '/-flto/d' \
+ src/makefile || die
}
src_configure() {
@@ -35,18 +39,20 @@ src_configure() {
src_compile() {
append-cflags -std=c11
+
emake -C src CC="$(tc-getCC)" \
NE_GLOBAL_DIR="/usr/share/${PN}" \
OPTS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
"${PN}"
}
src_install() {
- dobin "src/${PN}"
+ dobin src/${PN}
- insinto "/usr/share/${PN}/syntax"
+ insinto /usr/share/${PN}/syntax
doins syntax/*.jsf
- doman "doc/${PN}.1"
+ doman doc/${PN}.1
dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
}