summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/pluma')
-rw-r--r--app-editors/pluma/Manifest3
-rw-r--r--app-editors/pluma/metadata.xml12
-rw-r--r--app-editors/pluma/pluma-1.26.1.ebuild (renamed from app-editors/pluma/pluma-1.24.2.ebuild)59
-rw-r--r--app-editors/pluma/pluma-1.28.0.ebuild82
4 files changed, 122 insertions, 34 deletions
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index c481a1b9a671..07fec3ac564c 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1 +1,2 @@
-DIST pluma-1.24.2.tar.xz 3745160 BLAKE2B ed855b19f1ab80cb6ef9bc175eea3c2af386b1e45123bc0e3ad93d1964efb4822fe1b3d7490308357fcff96557bb6189f081a467f41a6907e76a1961de8f23d3 SHA512 588640744f8a0bec08d0c51c0309380a57cb6319c98124885e30d05e7dd8488ba7bd5acec1bf21fb0d6832626ae8925b24cd241202265af1a631a91313cdad2b
+DIST pluma-1.26.1.tar.xz 3824664 BLAKE2B e5ee5c2efeec90fb6733fac1077c870c79a386b3ab28d71a17929f144ecf9ae73ab66dc1a806504d7cb244bdd3c9ad63b7cccb5fb8f1f44b7b44a1076948a0e7 SHA512 bc4f621736d93df07fc2dc434a25c5a5acaf0d2c958eac43bd0061d4b664cae9b9eac1fffc47afa1509fd64b3c93a77ca62737428b034ca25997ebee432d5eb3
+DIST pluma-1.28.0.tar.xz 3866800 BLAKE2B 10813717b7d18a0836059a10deb67a61b00a73cf3d5b18f12a9e760b8b65053b3a82dc0ac9af898d9f2bb4d6998db536bcaef143024ae91f9035fe6e1ee72fea SHA512 8f21aabed46a70dfe8446ddf6db5cc4326782328d0b8dd3689c8b906cc8d4b746712c6b9decfa48ef028bdbb8a0b1c6a2ec43def23488ae55cfd59aafd5a691a
diff --git a/app-editors/pluma/metadata.xml b/app-editors/pluma/metadata.xml
index c28d596be470..fbb8c2a0c1a3 100644
--- a/app-editors/pluma/metadata.xml
+++ b/app-editors/pluma/metadata.xml
@@ -1,10 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>mate@gentoo.org</email>
- <name>Gentoo MATE Desktop</name>
- </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>immoloism@gmail.com</email>
+ <name>Ian Jordan</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">mate-desktop/pluma</remote-id>
</upstream>
diff --git a/app-editors/pluma/pluma-1.24.2.ebuild b/app-editors/pluma/pluma-1.26.1.ebuild
index 22ecdfa87638..92953d64b895 100644
--- a/app-editors/pluma/pluma-1.24.2.ebuild
+++ b/app-editors/pluma/pluma-1.26.1.ebuild
@@ -1,38 +1,34 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit mate python-single-r1 virtualx gnome2-utils
-PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9,3_10} )
-
-inherit mate python-single-r1 virtualx
+DESCRIPTION="Pluma text editor for the MATE desktop"
-if [[ ${PV} != 9999 ]]; then
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
fi
-DESCRIPTION="Pluma text editor for the MATE desktop"
LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
-SLOT="0"
-
+SLOT=0
IUSE="+introspection spell test"
-
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
-# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
-# https://github.com/mate-desktop/mate-text-editor/issues/33
-RESTRICT="test"
-
-COMMON_DEPEND="dev-libs/atk
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
>=dev-libs/glib-2.50:2
- >=dev-libs/libpeas-1.2.0[gtk]
+ >=dev-libs/libpeas-1.2.0:0[gtk]
>=dev-libs/libxml2-2.5:2
x11-libs/cairo
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.22:3[introspection?]
- >=x11-libs/gtksourceview-3.0.0:3.0
+ >=x11-libs/gtksourceview-4.0.2:4
x11-libs/libICE
x11-libs/libX11
>=x11-libs/libSM-1.0
@@ -42,28 +38,33 @@ COMMON_DEPEND="dev-libs/atk
>=app-text/enchant-1.6:=
>=app-text/iso-codes-0.35
)
- !!app-editors/mate-text-editor
"
-
-RDEPEND="${PYTHON_DEPS}
- ${COMMON_DEPEND}
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
>=mate-base/mate-desktop-1.9[introspection?]
virtual/libintl
"
-
DEPEND="${COMMON_DEPEND}
~app-text/docbook-xml-dtd-4.1.2
- app-text/rarian
- >=app-text/scrollkeeper-dtd-1:1.0
app-text/yelp-tools
dev-util/glib-utils
dev-util/gtk-doc
- dev-util/gtk-doc-am
- >=sys-devel/libtool-2.2.6:2
+ dev-build/gtk-doc-am
+ >=dev-build/libtool-2.2.6:2
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
+MATE_FORCE_AUTORECONF=true
+
+src_prepare() {
+ # Test require gvfs sftp fs mounted and schema's installed. Skip this one.
+ # https://github.com/mate-desktop/mate-text-editor/issues/33
+ sed -e '/+= document-saver/d' -i tests/Makefile.am || die
+
+ mate_src_prepare
+}
+
src_configure() {
mate_src_configure \
$(use_enable introspection) \
@@ -73,9 +74,9 @@ src_configure() {
src_test() {
# FIXME: This should be handled at eclass level.
- "${EPREFIX%/}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ "${EPREFIX}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
unset DBUS_SESSION_BUS_ADDRESS
-
- GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+ local -x GSETTINGS_SCHEMA_DIR="${S}/data"
+ virtx emake check
}
diff --git a/app-editors/pluma/pluma-1.28.0.ebuild b/app-editors/pluma/pluma-1.28.0.ebuild
new file mode 100644
index 000000000000..209753262d10
--- /dev/null
+++ b/app-editors/pluma/pluma-1.28.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit mate python-single-r1 virtualx
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT=0
+IUSE="+introspection spell test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libpeas-1.2.0:0[gtk]
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0.2:4
+ x11-libs/libICE
+ x11-libs/libX11
+ >=x11-libs/libSM-1.0
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ spell? (
+ >=app-text/enchant-1.6:=
+ >=app-text/iso-codes-0.35
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=mate-base/mate-desktop-1.9[introspection?]
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/yelp-tools
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=dev-build/libtool-2.2.6:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+MATE_FORCE_AUTORECONF=true
+
+src_prepare() {
+ # Test require gvfs sftp fs mounted and schema's installed. Skip this one.
+ # https://github.com/mate-desktop/mate-text-editor/issues/33
+ sed -e '/+= document-saver/d' -i tests/Makefile.am || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EPREFIX}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ local -x GSETTINGS_SCHEMA_DIR="${S}/data"
+ virtx emake check
+}