summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-8.2.0814-r100.ebuild')
-rw-r--r--app-editors/vim/vim-8.2.0814-r100.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-editors/vim/vim-8.2.0814-r100.ebuild b/app-editors/vim/vim-8.2.0814-r100.ebuild
index 085e62c4a3f7..c6cf07318e82 100644
--- a/app-editors/vim/vim-8.2.0814-r100.ebuild
+++ b/app-editors/vim/vim-8.2.0814-r100.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
SLOT="0"
LICENSE="vim"
-IUSE="X acl cscope debug gpm lua minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
+IUSE="X acl cscope debug gpm lua ipv6 minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -228,6 +228,12 @@ src_configure() {
)
fi
+ if ! use ipv6; then
+ myconf+=(
+ vim_cv_ipv6_networking=no
+ )
+ fi
+
# don't test USE=X here ... see bug #19115
# but need to provide a way to link against X ... see bug #20093
myconf+=(