summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-9999.ebuild')
-rw-r--r--app-editors/vim/vim-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 62ce11b27b08..0afdaaef7172 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# Please bump with app-editors/vim-core and app-editors/gvim
@@ -9,7 +9,7 @@ VIM_VERSION="8.2"
LUA_COMPAT=( lua5-1 luajit )
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby26 ruby27"
inherit vim-doc flag-o-matic bash-completion-r1 lua-single python-single-r1 ruby-single desktop xdg-utils
@@ -80,6 +80,8 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]] ; then
+ rm "${WORKDIR}"/patches/006-vim-8.0.0617-crosscompile.patch || die
+
# Gentoo patches to fix runtime issues, cross-compile errors, etc
eapply "${WORKDIR}"/patches/
fi
@@ -273,6 +275,10 @@ src_test() {
# Don't let vim talk to X
unset DISPLAY
+ # Arch and opensuse seem to do this and at this point, I'm willing
+ # to try anything to avoid random test hangs!
+ export TERM=xterm
+
# See https://github.com/vim/vim/blob/f08b0eb8691ff09f98bc4beef986ece1c521655f/src/testdir/runtest.vim#L5
# for more information on test variables we can use.
# Note that certain variables need vim-compatible regex (not PCRE), see e.g.
@@ -287,7 +293,11 @@ src_test() {
# Fragile and depends on TERM(?)
# - Test_spelldump_bang
# Hangs.
- export TEST_SKIP_PAT='\(Test_expand_star_star\|Test_exrc\|Test_job_tty_in_out\|Test_spelldump_bang\)'
+ # - Test_fuzzy_completion_env
+ # Too sensitive to leaked environment variables.
+ # - Test_term_mouse_multiple_clicks_to_select_mode
+ # Hangs.
+ export TEST_SKIP_PAT='\(Test_expand_star_star\|Test_exrc\|Test_job_tty_in_out\|Test_spelldump_bang\|Test_fuzzy_completion_env\|Test_term_mouse_multiple_clicks_to_select_mode\)'
emake -j1 -C src/testdir nongui
}