summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/okteta-0.25.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index 3bc9acc020a5..9de5cd0330bb 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1 +1,2 @@
+DIST okteta-0.25.0.tar.xz 951328 BLAKE2B eaa294fbcaf2257dac42084bd7e6494aa6878a9b21a2a832ca2f13ac4fca550f1dca55311a4a9e4b0102f73f16e5ad993a3f8e068f79a5f6e664c477e6412b37 SHA512 651a6d01833427df6ad7cb5d5e319fcc46113a214189702574647e87921d97db5381f2e5e797c3d8b7f1ba314eac6334aef738e648e82d9c1c9198144152a90c
DIST okteta-17.12.3.tar.xz 962772 BLAKE2B 4a347db4db1d248ccb73e2ab77d4b10449ccea2e1e23ae7770a338f1c96f3990de4a3362b566abde29d47ef4b1084614e219ea646e4b0704ecac048a4559d921 SHA512 d89bcd46001336d912f2d3f08247cdb13a02688316f078455e851feae03b638688683df2779c19089481b69baa2a582fd063d3180ebe66962ab249fc39c3850d
diff --git a/app-editors/okteta/okteta-0.25.0.ebuild b/app-editors/okteta/okteta-0.25.0.ebuild
new file mode 100644
index 000000000000..89727e9e83b1
--- /dev/null
+++ b/app-editors/okteta/okteta-0.25.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://www.kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ -DBUILD_DESIGNERPLUGIN=$(usex designer)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}