summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/compat')
-rw-r--r--app-emacs/compat/Manifest3
-rw-r--r--app-emacs/compat/compat-28.1.2.0.ebuild43
-rw-r--r--app-emacs/compat/compat-29.1.4.5.ebuild (renamed from app-emacs/compat/compat-28.1.1.3.ebuild)28
-rw-r--r--app-emacs/compat/metadata.xml8
4 files changed, 26 insertions, 56 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 298a7091b2e5..6e0e36dbf0f1 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,2 +1 @@
-DIST compat-28.1.1.3.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d758224ad37c0b7fbbd21221b0d2ffd68be805483f3e9577866f02079c83a5686918c87a1ed7c67c9acdd64aa3a560b SHA512 d65e5ce666607cd6d26cf771d6878caeb6641aff0fc924ec901955c1a03b6fe42e3527220448fa92a8d6c3f5bd65e6f915ed4ada1be01a29d7919f916826e48f
-DIST compat-28.1.2.0.tar.gz 72597 BLAKE2B 82186713370fed7f97eb057cb330d77c1d758224ad37c0b7fbbd21221b0d2ffd68be805483f3e9577866f02079c83a5686918c87a1ed7c67c9acdd64aa3a560b SHA512 d65e5ce666607cd6d26cf771d6878caeb6641aff0fc924ec901955c1a03b6fe42e3527220448fa92a8d6c3f5bd65e6f915ed4ada1be01a29d7919f916826e48f
+DIST compat-29.1.4.5.tar.gz 130079 BLAKE2B 84b3293bec535d7f653d0aa3fac069e230c030ccf809d0a606b068d9d663e078274d15d57ca56fc180208de69ae4fee554fbc3d5e8c78394789ee756665e980f SHA512 9682224a1ab5238c7f584121652c55df257fd050279e8356632b2aafef4045dc89b2dfd20cf8f5030dda1d96db40c993cdc3ac0efd0263d23beee8310def0849
diff --git a/app-emacs/compat/compat-28.1.2.0.ebuild b/app-emacs/compat/compat-28.1.2.0.ebuild
deleted file mode 100644
index 8a61c3a356a2..000000000000
--- a/app-emacs/compat/compat-28.1.2.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-H=2c3233c0e09ef34176787b6e3da4319751ad91e7
-NEED_EMACS=24
-
-inherit elisp
-
-DESCRIPTION="Compatibility libraries for Emacs"
-HOMEPAGE="https://git.sr.ht/~pkal/compat/"
-SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${H}
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="sys-apps/texinfo"
-
-ELISP_TEXINFO="${PN}.texi"
-
-src_compile() {
- emake compile ${PN}.info
-}
-
-src_test() {
- local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
- if [[ "${has_json}" != t ]] ; then
- local line
- while read line ; do
- ewarn "${line}"
- done <<-EOF
- Your current Emacs version does not support native JSON parsing,
- which is required for running tests of ${CATEGORY}/${PN}.
- Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
- to select that version.
- EOF
- else
- emake test
- fi
-}
diff --git a/app-emacs/compat/compat-28.1.1.3.ebuild b/app-emacs/compat/compat-29.1.4.5.ebuild
index 8a61c3a356a2..f9891ce90b16 100644
--- a/app-emacs/compat/compat-28.1.1.3.ebuild
+++ b/app-emacs/compat/compat-29.1.4.5.ebuild
@@ -1,28 +1,36 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-H=2c3233c0e09ef34176787b6e3da4319751ad91e7
-NEED_EMACS=24
-
inherit elisp
DESCRIPTION="Compatibility libraries for Emacs"
-HOMEPAGE="https://git.sr.ht/~pkal/compat/"
-SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${H}
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-compat/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-BDEPEND="sys-apps/texinfo"
+BDEPEND="
+ sys-apps/texinfo
+"
ELISP_TEXINFO="${PN}.texi"
src_compile() {
- emake compile ${PN}.info
+ emake compile "${PN}.info"
}
src_test() {
diff --git a/app-emacs/compat/metadata.xml b/app-emacs/compat/metadata.xml
index 3264e3c57176..1200c1ebc1c4 100644
--- a/app-emacs/compat/metadata.xml
+++ b/app-emacs/compat/metadata.xml
@@ -1,9 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
<pkgmetadata>
<maintainer type="project">
<email>gnu-emacs@gentoo.org</email>
<name>Gentoo GNU Emacs project</name>
</maintainer>
- <stabilize-allarches/>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/emacs-compat/compat/issues/</bugs-to>
+ <remote-id type="github">emacs-compat/compat</remote-id>
+ <remote-id type="sourcehut">~pkal/compat</remote-id>
+ </upstream>
</pkgmetadata>