summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/dashboard')
-rw-r--r--app-emacs/dashboard/Manifest2
-rw-r--r--app-emacs/dashboard/dashboard-1.8.0.ebuild48
-rw-r--r--app-emacs/dashboard/dashboard-1.8.0_pre20220406.ebuild38
-rw-r--r--app-emacs/dashboard/dashboard-9999.ebuild48
-rw-r--r--app-emacs/dashboard/files/dashboard-1.8.0-dashboard-widgets.el-banners.patch (renamed from app-emacs/dashboard/files/dashboard-dashboard-widgets.el-banners.patch)0
-rw-r--r--app-emacs/dashboard/metadata.xml1
6 files changed, 98 insertions, 39 deletions
diff --git a/app-emacs/dashboard/Manifest b/app-emacs/dashboard/Manifest
index 20e1b7ef9544..7783d4906a36 100644
--- a/app-emacs/dashboard/Manifest
+++ b/app-emacs/dashboard/Manifest
@@ -1 +1 @@
-DIST dashboard-1.8.0_pre20220406.tar.gz 191442 BLAKE2B 8b105d8ed9b31e7439cc55b85c9e0bb46739fcb26f9e1e605492a552cbcfe9799794be6239b6c622bfbfc2f850d20f2944f759010eb502bcb75edb570ae7e5b8 SHA512 b3b714bbee034fecbf1172dccd5eebc38373c11a510c532a7b9ba31cac79daafe7e9ccf7c5e622abbdb44817c966f100ec4f7a447e8b0370f9d7e66ff55e45ca
+DIST dashboard-1.8.0.tar.gz 195751 BLAKE2B 590ee410bf7d9b613b558f2ddbb032a00ea3034c02311da76d8dc8ff4f5260263dbb335dd05ee22b4bff42910ed63b0421f6737250d5971358566a2b32054aa3 SHA512 a15d3200cd0a658c5b37a50b3f4a693c1d027faba6797e88203633f4c40fd26e576afdb4e66205ba3c50f2a73e0acc9ff7f26afa7e09f7ca080a0c38742b84cf
diff --git a/app-emacs/dashboard/dashboard-1.8.0.ebuild b/app-emacs/dashboard/dashboard-1.8.0.ebuild
new file mode 100644
index 000000000000..6252d3ff922d
--- /dev/null
+++ b/app-emacs/dashboard/dashboard-1.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Extensible Emacs dashboard, with sections like bookmarks, agenda and more"
+HOMEPAGE="https://github.com/emacs-dashboard/emacs-dashboard/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emacs-dashboard/emacs-${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-dashboard/emacs-${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/emacs-${PN}-${PV}
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.md README.org etc )
+PATCHES=( "${FILESDIR}"/${PN}-1.8.0-dashboard-widgets.el-banners.patch )
+
+ELISP_REMOVE=( .dir-locals.el )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i dashboard-widgets.el || die
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L test -l ${PN}.el -l test/activate.el || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}"/${PN}
+ doins -r banners
+}
diff --git a/app-emacs/dashboard/dashboard-1.8.0_pre20220406.ebuild b/app-emacs/dashboard/dashboard-1.8.0_pre20220406.ebuild
deleted file mode 100644
index 88cc08a233ff..000000000000
--- a/app-emacs/dashboard/dashboard-1.8.0_pre20220406.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-H=69f98f5a89451c0881d0abb34ad57dd71616006a
-NEED_EMACS=26.1
-
-inherit elisp
-
-DESCRIPTION="Extensible Emacs dashboard, with sections for bookmarks, projects, agenda and more"
-HOMEPAGE="https://github.com/emacs-dashboard/emacs-dashboard/"
-SRC_URI="https://github.com/emacs-dashboard/emacs-${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/emacs-${PN}-${H}
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="test" # tests not in the repository, require "Eask"
-
-DOCS=( CHANGELOG.md README.org etc )
-PATCHES=( "${FILESDIR}"/${PN}-dashboard-widgets.el-banners.patch )
-
-ELISP_REMOVE=( .dir-locals.el )
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- elisp_src_prepare
-
- sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i dashboard-widgets.el || die
-}
-
-src_install() {
- elisp_src_install
-
- insinto "${SITEETC}"/${PN}
- doins -r banners
-}
diff --git a/app-emacs/dashboard/dashboard-9999.ebuild b/app-emacs/dashboard/dashboard-9999.ebuild
new file mode 100644
index 000000000000..8b610651c79f
--- /dev/null
+++ b/app-emacs/dashboard/dashboard-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Extensible Emacs dashboard, with sections like bookmarks, agenda and more"
+HOMEPAGE="https://github.com/emacs-dashboard/emacs-dashboard/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emacs-dashboard/emacs-${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-dashboard/emacs-${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/emacs-${PN}-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.md README.org etc )
+PATCHES=( "${FILESDIR}"/${PN}-1.8.0-dashboard-widgets.el-banners.patch )
+
+ELISP_REMOVE=( .dir-locals.el )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i dashboard-widgets.el || die
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L test -l ${PN}.el -l test/activate.el || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}"/${PN}
+ doins -r banners
+}
diff --git a/app-emacs/dashboard/files/dashboard-dashboard-widgets.el-banners.patch b/app-emacs/dashboard/files/dashboard-1.8.0-dashboard-widgets.el-banners.patch
index 9ce24c2d9bd6..9ce24c2d9bd6 100644
--- a/app-emacs/dashboard/files/dashboard-dashboard-widgets.el-banners.patch
+++ b/app-emacs/dashboard/files/dashboard-1.8.0-dashboard-widgets.el-banners.patch
diff --git a/app-emacs/dashboard/metadata.xml b/app-emacs/dashboard/metadata.xml
index dbd2fb8bfbca..888bda3ae5f8 100644
--- a/app-emacs/dashboard/metadata.xml
+++ b/app-emacs/dashboard/metadata.xml
@@ -11,4 +11,5 @@
<bugs-to>https://github.com/emacs-dashboard/emacs-dashboard/issues/</bugs-to>
<remote-id type="github">emacs-dashboard/emacs-dashboard</remote-id>
</upstream>
+ <stabilize-allarches />
</pkgmetadata>