summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/desktop+/desktop+-0.2.ebuild')
-rw-r--r--app-emacs/desktop+/desktop+-0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/desktop+/desktop+-0.2.ebuild b/app-emacs/desktop+/desktop+-0.2.ebuild
new file mode 100644
index 000000000000..f16dccf10541
--- /dev/null
+++ b/app-emacs/desktop+/desktop+-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="desktop+ extends standard desktop module"
+HOMEPAGE="https://github.com/ffevotte/desktop-plus"
+SRC_URI="https://github.com/ffevotte/desktop-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/dash app-emacs/f"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/desktop-plus-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}