summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/magit/magit-2.6.1.ebuild')
-rw-r--r--app-emacs/magit/magit-2.6.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/magit/magit-2.6.1.ebuild b/app-emacs/magit/magit-2.6.1.ebuild
new file mode 100644
index 000000000000..90e43f10315c
--- /dev/null
+++ b/app-emacs/magit/magit-2.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="http://magit.vc/"
+SRC_URI="https://github.com/magit/magit/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${P}/lisp"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="../Documentation/*.texi"
+DOCS="../README.md ../Documentation/AUTHORS.md ../Documentation/${PV}.txt"
+
+DEPEND=">=app-emacs/dash-2.12.1 >=app-emacs/with-editor-2.5.0"
+RDEPEND="${DEPEND} >=dev-vcs/git-1.9.4"