summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/mmm-mode/mmm-mode-0.5.1.ebuild')
-rw-r--r--app-emacs/mmm-mode/mmm-mode-0.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/mmm-mode/mmm-mode-0.5.1.ebuild b/app-emacs/mmm-mode/mmm-mode-0.5.1.ebuild
new file mode 100644
index 000000000000..1c01b6f927f3
--- /dev/null
+++ b/app-emacs/mmm-mode/mmm-mode-0.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Enables the user to edit different parts of a file in different major modes"
+HOMEPAGE="http://mmm-mode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-emacs
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo *.info*
+ dodoc AUTHORS ChangeLog FAQ NEWS README README.Mason TODO
+}