summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild')
-rw-r--r--app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild b/app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild
new file mode 100644
index 000000000000..325ce2045ec9
--- /dev/null
+++ b/app-emacs/with-simulated-input/with-simulated-input-3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp macro to simulate user input non-interactively"
+HOMEPAGE="https://github.com/DarwinAwardWinner/with-simulated-input/"
+SRC_URI="https://github.com/DarwinAwardWinner/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+DOCS=( README.md )
+ELISP_REMOVE="tests/test-${PN}.el" # Remove failing tests; 11/49 specs
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L tests --traceback full tests || die
+}