summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/aqemu')
-rw-r--r--app-emulation/aqemu/aqemu-0.9.2.ebuild1
-rw-r--r--app-emulation/aqemu/files/aqemu-0.9.2-qtbindir.patch15
2 files changed, 16 insertions, 0 deletions
diff --git a/app-emulation/aqemu/aqemu-0.9.2.ebuild b/app-emulation/aqemu/aqemu-0.9.2.ebuild
index cbe0aa57ee03..bdf8926c6a47 100644
--- a/app-emulation/aqemu/aqemu-0.9.2.ebuild
+++ b/app-emulation/aqemu/aqemu-0.9.2.ebuild
@@ -25,6 +25,7 @@ RDEPEND="app-emulation/qemu
dev-qt/qtprintsupport:5"
DOCS="AUTHORS CHANGELOG README TODO"
+PATCHES=( "${FILESDIR}/${PN}-0.9.2-qtbindir.patch" )
src_configure() {
local mycmakeargs=(
diff --git a/app-emulation/aqemu/files/aqemu-0.9.2-qtbindir.patch b/app-emulation/aqemu/files/aqemu-0.9.2-qtbindir.patch
new file mode 100644
index 000000000000..5c5548058427
--- /dev/null
+++ b/app-emulation/aqemu/files/aqemu-0.9.2-qtbindir.patch
@@ -0,0 +1,15 @@
+Ensure the Qt 5 version of rcc is used instead of whatever is in $PATH.
+
+Gentoo-bug: 589332
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -285,7 +285,7 @@
+
+ SET( _out ${CMAKE_CURRENT_SOURCE_DIR}/${_basename}.rcc )
+
+- ADD_CUSTOM_COMMAND( OUTPUT ${_out} COMMAND rcc ARGS ${_in} -binary -o ${_out} DEPENDS ${_in} )
++ ADD_CUSTOM_COMMAND( OUTPUT ${_out} COMMAND ${Qt5Core_RCC_EXECUTABLE} ARGS ${_in} -binary -o ${_out} DEPENDS ${_in} )
+
+ SET( ${_sources} ${${_sources}} ${_out} )
+ ENDFOREACH( curFile )