summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/crun')
-rw-r--r--app-emulation/crun/Manifest1
-rw-r--r--app-emulation/crun/crun-0.19.1-r1.ebuild70
-rw-r--r--app-emulation/crun/files/libcrun-linkage.patch29
-rw-r--r--app-emulation/crun/metadata.xml31
4 files changed, 0 insertions, 131 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
deleted file mode 100644
index 7ddc8f69e7a2..000000000000
--- a/app-emulation/crun/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST crun-0.19.1.tar.gz 1870594 BLAKE2B 1780a2936ff39ec80836c4c9ae072e2fc30703a31a79786337290c62dd433b5a35dcfa953be370703d1baab3de93fdb376c99ab76dff1470883c61726c313144 SHA512 f93f79d1d63d6749bcf92d48542d9555f3ad47657c959c7c06701861d7a5a4171969f00f6dff3878286970a48aba3314c25e35c005463e606533b0ff7843d994
diff --git a/app-emulation/crun/crun-0.19.1-r1.ebuild b/app-emulation/crun/crun-0.19.1-r1.ebuild
deleted file mode 100644
index 0590fee263af..000000000000
--- a/app-emulation/crun/crun-0.19.1-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit autotools python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc64"
-IUSE="+bpf +caps criu +seccomp systemd static-libs"
-
-DEPEND="
- sys-kernel/linux-headers
- >=dev-libs/yajl-2.0.0
- caps? ( sys-libs/libcap )
- criu? ( >=sys-process/criu-3.15 )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
-DOCS=( README.md )
-
-PATCHES=( "${FILESDIR}/libcrun-linkage.patch" )
-
-src_prepare() {
- default
-
- # for libcrun-linkage.patch
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable bpf)
- $(use_enable caps)
- $(use_enable criu)
- $(use_enable seccomp)
- $(use_enable systemd)
- $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C libocispec
- emake crun
-}
-
-src_install() {
- emake "DESTDIR=${D}" install-exec
- doman crun.1
- einstalldocs
-}
diff --git a/app-emulation/crun/files/libcrun-linkage.patch b/app-emulation/crun/files/libcrun-linkage.patch
deleted file mode 100644
index 72156ac931c8..000000000000
--- a/app-emulation/crun/files/libcrun-linkage.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 7cfdf094071fcff038bab573c1eeee599fa17b16 Mon Sep 17 00:00:00 2001
-From: Georgy Yakovlev <gyakovlev@gentoo.org>
-Date: Mon, 2 Aug 2021 03:53:25 -0700
-Subject: [PATCH] Makefile.am: link libcrun to $(FOUND_LIBS)
-
-otherwise libcrun consumers fail at runtime with
-symbol lookup errors
-
-Closes: https://github.com/containers/crun/issues/711
-Issue: https://github.com/containers/crun/issues/340
-Downstream-bug: https://bugs.gentoo.org/717750
-Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
----
- Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index 150e933a..7e5a4406 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -46,7 +46,7 @@ libocispec/libocispec.la:
-
- libcrun_la_SOURCES = $(libcrun_SOURCES)
- libcrun_la_CFLAGS = -I $(abs_top_builddir)/libocispec/src -I $(abs_top_srcdir)/libocispec/src -fvisibility=hidden
--libcrun_la_LIBADD = libocispec/libocispec.la $(maybe_libyajl.la)
-+libcrun_la_LIBADD = libocispec/libocispec.la $(FOUND_LIBS) $(maybe_libyajl.la)
- libcrun_la_LDFLAGS = -Wl,--version-script=$(abs_top_srcdir)/libcrun.lds
-
- # build a version with all the symbols visible for testing
diff --git a/app-emulation/crun/metadata.xml b/app-emulation/crun/metadata.xml
deleted file mode 100644
index c87b3b38a78c..000000000000
--- a/app-emulation/crun/metadata.xml
+++ /dev/null
@@ -1,31 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>robert@gnzler.io</email>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <longdescription lang="en">
- While most of the tools used in the Linux containers ecosystem are written in
- Go, crun authors believe C is a better fit for a lower level tool like a
- container runtime. runc; the most used implementation of the OCI runtime specs
- written in Go, re-execs itself and use a module written in C for setting up
- the environment before the container process starts.
-
- crun aims to be also usable as a library that can be easily included in
- programs without requiring an external process for managing OCI containers.
- </longdescription>
- <upstream>
- <changelog>https://github.com/containers/crun/releases</changelog>
- <remote-id type="github">containers/crun</remote-id>
- </upstream>
- <use>
- <flag name="bpf">Enable in Kernel, eBPF (enhanced Berkley Packet Filter)
- support for managing device controllers.
- </flag>
- <flag name="criu">Enable CRIU based checkpoint/restore support</flag>
- </use>
-</pkgmetadata>